summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMikael Eriksson2019-11-14 19:29:21 +0100
committerMikael Eriksson2019-11-14 19:29:21 +0100
commitb275ef35d69989fa81caf0fbae4abbf4d1138bc6 (patch)
treef070683f043c209ac8b240c726cdec7a928a6bdd /PKGBUILD
parent110977d9e90c32748ef4cf03107859508947fd5b (diff)
downloadaur-b275ef35d69989fa81caf0fbae4abbf4d1138bc6.tar.gz
0.4.5-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 9 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a478e8f3a95c..4652e71cdd80 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,25 +3,29 @@
# flashback_data_files.7z if from http://gtamp.com/PSP/reminiscencepsp.php
pkgname=reminiscence
-pkgver=0.3.7
+pkgver=0.4.5
pkgrel=1
pkgdesc="A rewrite of the flashback engine"
arch=('i686' 'x86_64')
url="http://cyxdown.free.fr/reminiscence/"
license=('GPL')
depends=('sdl2' 'libmodplug' 'zlib' 'bash' 'libtremor-svn')
-makedepends=('p7zip')
+makedepends=('p7zip' 'patch')
source=(http://cyxdown.free.fr/reminiscence/REminiscence-${pkgver}.tar.bz2
http://gtamp.com/PSP/flashback_data_files.7z
- reminiscence.sh)
-md5sums=('bee0bf58db306942bc625e89e3a62633'
+ reminiscence.sh
+ fix-makefile.patch)
+md5sums=('ebdb0027c77fceae39b4edfb1b231adc'
'f994412ad4246c587896dab7d2eb9627'
- '4ed0350e4b81e9ba305f90e157c75371')
+ '4ed0350e4b81e9ba305f90e157c75371'
+ '4e0815ccd056c38ab694ca77c03fac51')
noextract=('flashback_data_files.7z')
build() {
cd "$srcdir/REminiscence-$pkgver"
+ patch -p1 -i $srcdir/fix-makefile.patch
+
make CXX=g++ CXXFLAGS="-Wall -MMD \$(SDL_CFLAGS) -DUSE_MODPLUG -DUSE_ZLIB -O"
}