summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSam Burgos2021-12-23 10:52:00 -0600
committerSam Burgos2021-12-23 10:52:00 -0600
commit9440d0800430d1bf9c26915ec0574610518e16c5 (patch)
tree09839c1bb8f691365865a016fb061c79027eea6e /PKGBUILD
parente91884e1317b72ee1ab7153637223556dd409675 (diff)
downloadaur-9440d0800430d1bf9c26915ec0574610518e16c5.tar.gz
updating package to latest upstream version and correcting a major mistake on commit message
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD42
1 files changed, 27 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1c4cf4eb2b4e..627275b62536 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,38 +4,47 @@
pkgname=remmina-appindicator
_pkgname=remmina
epoch=1
-pkgver=1.4.10
+pkgver=1.4.23
pkgrel=1
-pkgdesc='remote desktop client written in GTK+ (compiled with appindicator)'
+pkgdesc='remote desktop client written in GTK+ (compiled with appindicator and with some basic plugins added)'
arch=(x86_64)
url=https://www.remmina.org/
license=(GPL)
depends=(
avahi
+ freerdp
libappindicator-gtk3
libgcrypt
+ libsecret
libsodium
libssh
+ libvncserver
vte3
+ webkit2gtk
)
optdepends=(
- 'freerdp: RDP plugin'
- 'libsecret: Secret plugin'
- 'libvncserver: VNC plugin'
- 'libxkbfile: NX plugin'
- 'nxproxy: NX plugin'
+ #'freerdp: RDP plugin'
+ #'libsecret: Secret plugin'
+ #'libvncserver: VNC plugin'
'spice-gtk: Spice plugin'
- 'telepathy-glib: Telepathy plugin'
- 'xorg-server-xephyr: XDMCP plugin'
-)
+ #'pyhoca-cli: X2Go plugin'
+ #'webkit2gtk: WWW plugin'
+ 'gtk-vnc: GVNC plugin'
+ 'kwallet: kwallet plugin'
+ 'gnome-terminal: external tools')
+
makedepends=(
cmake
freerdp
+ gobject-introspection
+ gtk-vnc
harfbuzz
+ kwallet
libvncserver
spice-gtk
spice-protocol
telepathy-glib
+ webkit2gtk
xorgproto
)
@@ -53,15 +62,18 @@ replaces=(
remmina
)
source=("$pkgname-$pkgver.tar.bz2::https://gitlab.com/Remmina/Remmina/-/archive/v${pkgver/rc/-rc}/Remmina-v${pkgver/rc/-rc}.tar.bz2")
-sha512sums=('ebd589b4237c59b11ac0ca349654177752f11ca221afa761247a1f49c6224c1e7cb51db40b87233ab2a724fb0ef76162db0d7c743becd41a2b8524eafe108f7f')
+sha512sums=('73ce0482d33ba8e7a0960e8f3de3982818de2f96578f00c0cc3d7043a97fa6dee0c71acc8be155df7fbd063cd498be190bb78d2ff668a16de0946b965951cf71')
build() {
- cd "$srcdir"/Remmina-v${pkgver/rc/-rc}/
- cmake \
+ cmake -S Remmina-v${pkgver/rc/-rc} -B build \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=/usr/lib \
- -DWITH_APPINDICATOR=ON .
- make
+ -DWITH_APPINDICATOR=ON \
+ -DWITH_NEWS=OFF \
+ -DWITH_KF5WALLET=ON \
+ -DWITH_X2GO=ON \
+ -DWITH_GVNC=ON
+ cmake --build build
}
package() {