summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMuflone2015-06-13 17:59:23 +0200
committerMuflone2015-06-13 17:59:23 +0200
commit027e3007982d6d502156ea90c376757a442ee0bf (patch)
tree60783851c25a456320d21f6a08388dea6248c608 /PKGBUILD
downloadaur-027e3007982d6d502156ea90c376757a442ee0bf.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..418fc9b01318
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Muflone http://www.muflone.com/contacts/english/
+
+pkgname=remmina-plugin-url
+pkgver=1.1.1.0
+pkgrel=2
+_builderver=1.1.0.0
+pkgdesc="A protocol plugin for Remmina to open an URL in an external browser."
+arch=('i686' 'x86_64')
+url="http://www.muflone.com/${pkgname}/"
+license=('GPL')
+depends=('gtk3' 'remmina')
+makedepends=('pkg-config' 'cmake')
+optdepends=(
+ 'firefox: for Mozilla Firefox option'
+ 'iceweasel: for Iceweasel option'
+ 'epiphany: for Epiphany option'
+)
+install="${pkgname}.install"
+source=("remmina-plugin-builder_${_builderver}.tar.gz::https://github.com/muflone/remmina-plugin-builder/archive/${_builderver}.tar.gz"
+ "${pkgname}_${pkgver}.tar.gz::https://github.com/muflone/${pkgname}/archive/${pkgver}.tar.gz")
+sha256sums=('0d41d50731ae25dfa1e66394cfa489d598cf491d36dbaf44d72ad921589e0960'
+ '5252bbdca11fba208f8da37c26a819003c94b014fa104e0246aa583a0448cc5f')
+
+build() {
+ [ -d build ] && rm -rf build
+ cp -r "remmina-plugin-builder-${_builderver}" build
+ cp -r "${pkgname}-${pkgver}"/* "build/remmina-plugin-to-build"
+ cd build
+ cmake -DCMAKE_INSTALL_PREFIX=/usr .
+ make
+}
+
+package() {
+ cd "${srcdir}/build/"
+ make DESTDIR="${pkgdir}" install
+}