summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMuflone2019-12-22 04:13:10 +0100
committerMuflone2019-12-22 04:13:10 +0100
commit7a0a8e2fc1f98c42125bdaf6cc5687a1a1fe3b43 (patch)
tree736054df1ace24a51a5acbe0794088accffc129d /PKGBUILD
parentf220cffceb935fc2a450f7717fea64f04dcb6d28 (diff)
downloadaur-7a0a8e2fc1f98c42125bdaf6cc5687a1a1fe3b43.tar.gz
Updated package remmina-plugin-url 1.3.0.0-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 6 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bbe1fa4562bb..f4bb7ab9b700 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,11 @@
# Maintainer: Muflone http://www.muflone.com/contacts/english/
pkgname=remmina-plugin-url
-pkgver=1.2.3.0
+pkgver=1.3.0.0
pkgrel=1
-_builderver=1.2.3.0
+_builderver=1.3.0.0
pkgdesc="A protocol plugin for Remmina to open an URL in an external browser."
-arch=('i686' 'x86_64')
+arch=('x86_64')
url="http://www.muflone.com/${pkgname}/"
license=('GPL')
depends=('gtk3' 'remmina')
@@ -14,22 +14,17 @@ optdepends=('firefox: for Mozilla Firefox option'
'iceweasel: for Iceweasel option'
'epiphany: for Epiphany option'
'midori: for Midori option')
-install="${pkgname}.install"
source=("remmina-plugin-builder_${_builderver}.tar.gz::https://github.com/muflone/remmina-plugin-builder/archive/${_builderver}.tar.gz"
"${pkgname}_${pkgver}.tar.gz::https://github.com/muflone/${pkgname}/archive/${pkgver}.tar.gz")
-sha256sums=('a36bfd9f97f462ba3af024e9a8e84df26bc6bed87281db9b6a24f2630f4deb56'
- '7e038c91c395f8f679898f80a65f8eefc2217f7ed9361666146ec2ef5f98797d')
-
-prepare() {
- msg2 'To build for Remmina < 1.2 set -DREMMINA_VER_1_1=ON'
-}
+sha256sums=('0e4e2d6a79dc569444016a5479b437016386985d96a958da7505c15b1695f98c'
+ 'a3a3aa01911ab46ac47c31b78dcd81eba5b43696f5508dc16ac843aeeded495b')
build() {
[ -d build ] && rm -rf build
cp -r "remmina-plugin-builder-${_builderver}" build
cp -r "${pkgname}-${pkgver}"/* "build/remmina-plugin-to-build"
cd build
- cmake -DCMAKE_INSTALL_PREFIX=/usr -DREMMINA_VER_1_1=OFF .
+ cmake -DCMAKE_INSTALL_PREFIX=/usr -DWITH_TRACE_CALLS=OFF .
make
}