summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPatrick Northon2024-02-08 13:02:39 -0500
committerPatrick Northon2024-02-08 13:02:39 -0500
commit3662a33a3f77380fb3301bb0091617610e0f794f (patch)
tree7106b5dad739dbe71ae0a00b157639452c5c9177 /PKGBUILD
parent592ef50fbab1c5f504cf725507355d5e9046c104 (diff)
downloadaur-3662a33a3f77380fb3301bb0091617610e0f794f.tar.gz
Fix depends in package() and remove games group requirement.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 2 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3d73f9ae5dfd..c9c017ba2d3f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
_pkgname=renpy
pkgname=${_pkgname}-git
-pkgver=8.2.0.24012702.r6.gc5a143c
+pkgver=8.2.0.24012702.r40.g9133530
pkgrel=1
pkgdesc="Visual novel engine Ren'Py along with its platdeps libs (dev channel)"
arch=('i686' 'x86_64')
@@ -56,7 +56,7 @@ build() {
}
package() {
- depends=('python-pefile' 'python-requests' 'python-rsa' 'python-six')
+ depends+=('python-pefile' 'python-requests' 'python-rsa' 'python-six')
#pack data
mkdir -p "$pkgdir/"{usr/share/{$_pkgname,doc/$_pkgname},}
@@ -73,9 +73,6 @@ package() {
install -d -m755 "$pkgdir/usr/share/renpy/lib/py3-linux-x86_64"
ln -s '/usr/bin/renpy' "$pkgdir/usr/share/renpy/lib/py3-linux-x86_64"
- chgrp -R games "$pkgdir"/usr/share/renpy/{the_question,tutorial}
- chmod g+w "$pkgdir"/usr/share/renpy/{the_question,tutorial}
-
#pack modules
cd 'module'
python -m installer --destdir="$pkgdir" dist/*.whl