summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPedroHLC2020-08-31 17:26:20 -0300
committerPedroHLC2020-08-31 17:26:20 -0300
commit238834a21e42e5b326d7c5c9b86d06fa6ba4434d (patch)
treef75600d99fed83e7df3f871d367b038f8d9bfdab /PKGBUILD
parent8cdc6ad61cc34abe0be4145465a6db060df594d3 (diff)
downloadaur-238834a21e42e5b326d7c5c9b86d06fa6ba4434d.tar.gz
@cassava suggestion
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a40e0b14e749..f5f5098ccb08 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,5 @@
# Maintainer: Pedro H Lara Campos <root@pedrohlc.com>
+# Contributor: Ben Morgan (@cassava)
# Contributor: bartus <szczepaniak.bartek+github@gmail.com>
# Contributor: Mark Wagie <mark.wagie@tutanota.com>
# Contributor: Alad Wenter <alad@mailbox.org>
@@ -12,7 +13,6 @@ url="https://github.com/cassava/repoctl"
license=('MIT')
depends=('pacman')
makedepends=('go-pie' 'git')
-options=()
source=("${_pkgname}::git+https://github.com/cassava/repoctl.git#branch=devel")
md5sums=('SKIP')
provides=('repoctl')
@@ -27,7 +27,7 @@ pkgver() {
build() {
cd "${srcdir}/${_pkgname}"
export CGO_LDFLAGS="${LDFLAGS}"
- export GOFLAGS="-buildmode=pie -trimpath -mod=readonly -modcacherw"
+ export GOFLAGS="-buildmode=pie -trimpath -mod=vendor -modcacherw"
export GOPATH="$srcdir"
go build
}