summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRichard Neumann2021-01-12 15:56:01 +0100
committerRichard Neumann2021-01-12 15:56:11 +0100
commite1051338df121e68c1ef5feb8714a6906861ce2d (patch)
treede509b8e471752b1799618d08333832d6c640ccc /PKGBUILD
parent61a373d596ca83744705d464910abe24caf490c0 (diff)
downloadaur-e1051338df121e68c1ef5feb8714a6906861ce2d.tar.gz
Updated to 1.2.8.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 12 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 605ee9493140..b7e50cadfd2a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,23 @@
# Maintainer: Richard Neumann aka. schard <mail at richard dash neumann period de>
pkgname='repotool'
-pkgver=1.2.7
-pkgrel=2
+pkgver=1.2.8
+pkgrel=1
pkgdesc='An arch linux repository management tool'
arch=('any')
url="https://github.com/coNQP/${pkgname}"
license=('GPLv3')
-depends=('python')
-source=("https://github.com/conqp/${pkgname}/archive/${pkgver}.tar.gz")
-sha256sums=('a20e6f950bbece6f6966c747443020a9218b38abfa65e9d7d8d06d8a7529cab2')
+depends=('python' 'python-setuptools')
+makedepends=('git' 'python-setuptools-scm')
+source=("${pkgname}::git+${url}.git#tag=${pkgver}")
+sha256sums=('SKIP')
+build() {
+ cd "${srcdir}/${pkgname}"
+ python setup.py build
+}
package() {
- cd "${pkgname}-${pkgver}"
- python setup.py install --root "${pkgdir}" --optimize=1
+ cd "${srcdir}/${pkgname}"
+ python setup.py install --root "${pkgdir}" --optimize=1 --skip-build
}