summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSantiago Torres2018-03-05 23:07:37 -0500
committerSantiago Torres2018-03-05 23:08:25 -0500
commit290bc84574d9ad18931ddbd4c3e696a0d42c769d (patch)
treefeb3d5b03cc4e5af2b60cbd35b7777dd2de45369 /PKGBUILD
parentaa1dd69ea4d24cdef7c779430e0a9de1a6b02c61 (diff)
downloadaur-290bc84574d9ad18931ddbd4c3e696a0d42c769d.tar.gz
clean up PKGBUILD
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 4 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6fe9be1d5a7d..d72cc8e9e3ce 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,28 @@
# Maintainer: Santiago Torres-Arias <santiago@archlinux.org>
# Contributor: kpcyrd <git@rxv.cc>
-pkgbase=reprotest
pkgname=('reprotest')
pkgver=0.7.7
-pkgrel=1
+pkgrel=2
pkgdesc="Run a process twice and check the output for reproducibility"
arch=('any')
license=('GPL2' 'GPL3')
url="https://anonscm.debian.org/cgit/reproducible/reprotest.git/"
-provides=("reprotest=$pkgver")
depends=('python' 'python-rstr' 'diffoscope' 'fakeroot' 'python-distro')
optdepends=('disorderfs>=0.5.2' 'python-progressbar>=3.34.3-1')
-makedepends=('python' 'python-setuptools')
source=(http://reproducible.alioth.debian.org/releases/reprotest/${pkgname}_${pkgver}.tar.xz{,.asc})
sha512sums=('b802d3614adacfd07f0c6cddab126af5fb621b9e2563e68d31634cb04ff402b4a5e688df27db95a8f1a70ea1e9f2c0f2fe22e5747cae3ece97846bc4c5c3a0a4'
'SKIP')
-validpgpkeys=("A405E58AB3725B396ED1B85C1318EFAC5FBBDBCE")
+validpgpkeys=("A405E58AB3725B396ED1B85C1318EFAC5FBBDBCE")
build() {
- cd "$srcdir/reprotest"
+ cd "$srcdir/${pkgname}"
python setup.py build
}
package() {
depends=('python' 'python-setuptools')
- cd "$srcdir/reprotest"
+ cd "$srcdir/${pkgname}"
python setup.py install --root="$pkgdir" --optimize=1
}