summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorArthur Zamarin2015-06-08 11:42:34 +0300
committerArthur Zamarin2015-06-08 11:42:34 +0300
commit757329ce00fb7294bbd2e95d665c0c0891150821 (patch)
treefecd69fb05af8b47eecb2dfa6b6700715199ef34 /PKGBUILD
downloadaur-757329ce00fb7294bbd2e95d665c0c0891150821.tar.gz
Initial Commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d14116f15960
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Arthur Zamarin <arthurzam@gmail.com>
+
+_pkgname=reredirect
+pkgname=${_pkgname}-git
+pkgver=v0.1.r5.ga80845a
+pkgrel=1
+pkgdesc="Tool to dynamicly redirect outputs of a running process"
+arch=(i686 x86_64)
+url="https://github.com/jerome-pouiller/${_pkgname}/"
+license=('custom')
+source=("${_pkgname}::git+git://github.com/jerome-pouiller/${_pkgname}.git")
+sha1sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ git describe --long --tags | sed -r 's/([^-]*-g)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$srcdir/${_pkgname}"
+ make
+}
+
+package() {
+ cd "$srcdir/${_pkgname}"
+ make PREFIX=/usr DESTDIR=${pkgdir} install
+} \ No newline at end of file