summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorShulhan2021-11-14 15:25:26 +0700
committerShulhan2021-12-04 01:15:37 +0700
commit01bb8fc91967957ee8eedcfa96f680680e19c250 (patch)
treeceb8b437b2f0cb338e9065490ef2c6b3abdcc266 /PKGBUILD
parentc11177dcdf82ca340a90cf14060d86ff9581a216 (diff)
downloadaur-01bb8fc91967957ee8eedcfa96f680680e19c250.tar.gz
all: update to latest release v4.0.0-dev
Changes, * Set minimum Go version to v1.16 * Remove /etc/rescached/hosts.d/hosts.block from backup * Install LICENSE only in /usr/share/licenses/rescached/ directory
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 9 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 07b7c61501a6..fc27893a5f29 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: shulhan <ms@kilabit.info>
pkgname=rescached-git
-pkgver=4.0.0.r0.g004ca8b
+pkgver=4.0.0.r6.g33b6afc
pkgrel=1
pkgdesc="Resolver/DNS cache daemon"
arch=('i686' 'x86_64' 'armv7h')
@@ -9,11 +9,15 @@ license=('custom:BSD')
depends=('bash')
provides=('rescached')
+makedepends=('git' 'go>=1.16')
-makedepends=('git' 'go>=1.14')
source=(
"$pkgname::git+https://github.com/shuLhan/rescached-go.git"
)
+## For testing on local.
+#source=(
+# "$pkgname::git+file:///home/ms/go/src/github.com/shuLhan/rescached-go"
+#)
sha1sums=(
'SKIP'
)
@@ -48,5 +52,7 @@ build() {
package() {
cd "$pkgname"
make PREFIX="$pkgdir" install
- install -Dm644 $srcdir/$pkgname/LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ rm -f ${pkgdir}/usr/share/rescached/LICENSE
+ rmdir ${pkgdir}/usr/share/rescached
+ install -Dm644 $srcdir/$pkgname/LICENSE "${pkgdir}/usr/share/licenses/rescached/LICENSE"
}