summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDimitris Kiziridis2020-06-16 01:16:48 +0300
committerDimitris Kiziridis2020-06-16 01:16:48 +0300
commitf0e33ee02bd6fb3602aa0f6b7f83acf19687c2bf (patch)
tree2e18dd92f7622cb287959676fc0221450b04c8d7 /PKGBUILD
downloadaur-f0e33ee02bd6fb3602aa0f6b7f83acf19687c2bf.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fdcf4fac7ac5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Dimitris Kiziridis <ragouel at outlook dot com>
+
+pkgname=responsively-bin
+pkgver=0.2.0
+pkgrel=1
+pkgdesc="A modified browser that helps in responsive web development"
+arch=('x86_64')
+url='https://responsively.app'
+license=('AGPL3')
+provides=('responsively')
+depends=('zlib')
+makedepends=('gendesk')
+options=('!strip')
+noextract=("${pkgname}-${pkgver}.AppImage")
+source=("${pkgname}-${pkgver}.AppImage::https://github.com/manojVivek/responsively-app/releases/download/v${pkgver}/ResponsivelyApp-${pkgver}.AppImage")
+sha256sums=('4bd488a0b2537e6c0137da058d4e2413864ef66c5535fbfbb09405cde209c8cf')
+
+package() {
+ chmod 755 ./${pkgname}-${pkgver}.AppImage
+ ./${pkgname}-${pkgver}.AppImage --appimage-extract
+ install -Dm644 squashfs-root/usr/share/icons/hicolor/256x256/apps/responsively-app.png "${pkgdir}/usr/share/pixmaps/responsively.png"
+ gendesk -f -n --pkgname "${pkgname%-bin}" \
+ --pkgdesc "$pkgdesc" \
+ --name "Responsively" \
+ --comment "$pkgdesc" \
+ --exec "${pkgname%-bin}" \
+ --categories 'Development;Application;' \
+ --icon "${pkgname%-bin}"
+ install -Dm644 "${pkgname%-bin}.desktop" -t "${pkgdir}/usr/share/applications"
+ install -d "${pkgdir}/usr/bin"
+ install -Dm755 "${srcdir}/${pkgname}-${pkgver}.AppImage" "${pkgdir}/opt/${pkgname%-bin}/${pkgname%-bin}.AppImage"
+ ln -s /opt/${pkgname%-bin}/${pkgname%-bin}.AppImage "${pkgdir}/usr/bin/responsively"
+} \ No newline at end of file