summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDario Ostuni2016-12-08 02:51:48 +0100
committerDario Ostuni2016-12-08 02:51:48 +0100
commit18a2eef7d50226711fa1be2cd6d57084114ece36 (patch)
tree99d1105edd236d3ffba14ad4ab4c1151e0d3b718 /PKGBUILD
downloadaur-18a2eef7d50226711fa1be2cd6d57084114ece36.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..eb1f00e5289f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Dario Ostuni <another.code.996@gmail.com>
+pkgname=restclient-cpp
+pkgver=0.4.4
+pkgrel=1
+pkgdesc="A simple REST client for C++"
+arch=('i686' 'x86_64' 'armv7h' 'aarch64')
+url="https://github.com/mrtazz/restclient-cpp"
+license=('MIT')
+depends=('curl')
+options=()
+source=("https://github.com/mrtazz/$pkgname/archive/$pkgver.tar.gz")
+sha256sums=('f89355d4a635d35e19082078a86c18af8e05e033361d474b20d7b8589257d05d')
+
+build() {
+ cd "$pkgname-$pkgver"
+ ./autogen.sh
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+}