summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMatthew Gamble2023-01-02 15:23:29 +1100
committerMatthew Gamble2023-01-02 15:23:29 +1100
commit9527b4580ae97ce04fe61ceb1058b09c156a5dca (patch)
tree498fed92e15c2e4734451a162ef433cef8c306d5 /PKGBUILD
parent2a5296f0e27f2a1a903ce84d0b69dfff1c913a76 (diff)
downloadaur-9527b4580ae97ce04fe61ceb1058b09c156a5dca.tar.gz
Update to latest release
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 8 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6e980795c782..e1c977e4ca15 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,17 +2,17 @@
# Contributor: Kyle Brennan <kyle@metalspork.xyz>
pkgname=resticprofile
-pkgver=0.16.0
-_commit_hash="433ecae5522c0cbb794dea3787d57cf0c44bf2c3"
+pkgver=0.19.0
+_commit_hash="01bbd7852d09fc05fcbda22ace207b315550c741"
pkgrel=1
-pkgdesc="Configuration profiles for restic backup"
+pkgdesc="Configuration profiles manager and scheduler for restic backup"
arch=("x86_64")
url="https://github.com/creativeprojects/resticprofile"
license=("GPL3")
depends=("glibc" "restic")
makedepends=("go")
source=("https://github.com/creativeprojects/resticprofile/archive/v${pkgver}.tar.gz")
-sha256sums=("082f74ffced8e4f35b86a22b40013faaba70a12a9f5b676b2f27c030f2c2510d")
+sha256sums=("304c370965735be61d0947d13bef18099a9cc1754bb7bd38350f690c057e808d")
build() {
cd "resticprofile-${pkgver}"
@@ -25,7 +25,7 @@ build() {
LC_ALL=C _build_date="$(date)"
- go mod vendor
+ #go mod vendor
go build -o resticprofile -v -ldflags "-X 'main.commit=${_commit_hash}' -X 'main.date=${_build_date}' -X 'main.builtBy=makepkg'"
}
@@ -40,4 +40,7 @@ package() {
install -Dm644 examples/* "${pkgdir}/usr/share/resticprofile/examples/"
install -dm755 "${pkgdir}/usr/share/resticprofile/contrib/systemd/"
install -Dm644 contrib/systemd/* "${pkgdir}/usr/share/resticprofile/contrib/systemd/"
+
+ install -Dm644 contrib/completion/bash-completion.sh "${pkgdir}/usr/share/bash-completion/completions/resticprofile"
+ install -Dm644 contrib/completion/zsh-completion.sh "${pkgdir}/usr/share/zsh/site-functions/_resticprofile"
}