summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJoaquim Monteiro2020-04-04 19:52:54 +0100
committerJoaquim Monteiro2020-04-04 19:52:54 +0100
commit554f0891973b003458304f3920fd22e7accdae93 (patch)
tree320a3b3af8547c2becfb834edcc073bb849a595a /PKGBUILD
downloadaur-ret-sync-gdb-git.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..604ef7f4e262
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: gmes78 <gmes.078 at gmail dot com>
+
+pkgname=ret-sync-gdb-git
+pkgver=r54.ba51775
+pkgrel=1
+pkgdesc="Set of plugins that help to synchronize a debugging session with a disassembler - GDB plugin"
+arch=(any)
+url="https://github.com/bootleg/ret-sync"
+license=('GPL')
+provides=('ret-sync-gdb')
+conflicts=('ret-sync-gdb')
+
+depends=('gdb')
+makedepends=('git')
+optdepends=('ret-sync-ghidra: Ghidra integration')
+
+source=('git+https://github.com/bootleg/ret-sync')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/ret-sync"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$srcdir/ret-sync/ext_gdb"
+ install -D -m644 sync.py "$pkgdir/usr/share/retsync/sync.py"
+}