summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorprofessorkaos642016-09-20 10:58:06 -0400
committerprofessorkaos642016-09-20 10:58:06 -0400
commit6b5228f20fd3a956db3e6fda5391926d6b4e471d (patch)
treeb84e76a42856d60ba87b9552bfb6087632cb4a39 /PKGBUILD
parentb68a1757a242b7c1dc99f2270c5115fec8eed1b2 (diff)
downloadaur-6b5228f20fd3a956db3e6fda5391926d6b4e471d.tar.gz
add default paths for cfg file
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 14 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 875a38aa3ea9..0d3a2bc42e45 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,10 +10,10 @@
# 'git+https://github.com/KhronosGroup/SPIRV-Cross.git#commit=5c24d99')
pkgname=retroarch-git
-pkgver=1.3.6.r1181.233925b
+pkgver=1.3.6.r1439.8095fa9
pkgrel=1
#epoch=1
-git_name=RetroArch
+_gitname=RetroArch
pkgdesc='Reference frontend for the libretro API (Git-latest)'
arch=('i686' 'x86_64')
conflicts=('retroarch')
@@ -37,21 +37,23 @@ optdepends=('libretro-overlays: Collection of overlays'
backup=('etc/retroarch.cfg')
source=('git+https://github.com/libretro/RetroArch.git'
'git+https://github.com/KhronosGroup/glslang.git'
- 'git+https://github.com/KhronosGroup/SPIRV-Cross.git')
+ 'git+https://github.com/KhronosGroup/SPIRV-Cross.git'
+ 'default-paths.patch')
sha256sums=('SKIP'
'SKIP'
- 'SKIP')
+ 'SKIP'
+ '68cca008fb0123d6f9b989a0dfd361f8de2a5c3dfe3670d0d04cb661bd9aea5c')
pkgver() {
- cd RetroArch
+ cd $_gitname
printf "%s" "$(git describe --first-parent --long --tags | sed 's/v//g;s/\([^-]*-\)g/r\1/;s/-/./g')"
}
prepare() {
- cd RetroArch
+ cd $_gitname
git submodule init deps/{glslang/glslang,SPIRV-Cross}
git config submodule.glslang.url ../glslang
@@ -62,7 +64,12 @@ prepare() {
build() {
- cd RetroArch
+ cd $_gitname
+
+ # Patch retroarch.cfg for sane defaults (core path, core info, joypad autoconfig)
+ msg2 "Patching retroarch.cfg for default paths"
+ patch -p1 < $srcdir/default-paths.patch
+
./configure \
--prefix='/usr' \
--disable-jack \