summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJulian Xhokaxhiu2015-11-29 12:00:43 +0100
committerJulian Xhokaxhiu2015-11-29 12:00:43 +0100
commit85c8cf96a6441433cc23de1c26613163f8d40353 (patch)
tree0dd795fcce72e146f7947cf95f0429a1ebfe88f2 /PKGBUILD
parentde5cbaffe2e9d724e77d7bcbd6213721560bb7fc (diff)
downloadaur-85c8cf96a6441433cc23de1c26613163f8d40353.tar.gz
Revert back to previous situation.
At least with this we have all the vc libraries linked.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD4
1 files changed, 3 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1fa15529dfd7..03cfdb3df17d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -28,7 +28,9 @@ pkgver() {
build() {
cd "${_gitname}"
- HAVE_VIDEOCORE=yes ./configure --prefix=/usr --disable-vg --disable-opengl --disable-gles --disable-fbo --disable-egl --disable-x11 --disable-sdl --disable-sdl2 --disable-pulse --disable-oss --disable-ffmpeg --disable-freetype --enable-neon --enable-dispmanx --enable-floathard --enable-udev
+ export CFLAGS="$CFLAGS -I/opt/vc/include"
+ export LDFLAGS="${LDFLAGS//-Wl,--as-needed} -L/opt/vc/lib/ -lGLESv2 -lEGL -lopenmaxil -lbcm_host -lvcos -lvchiq_arm -lpthread"
+ ./configure --prefix=/usr --disable-vg --disable-opengl --disable-gles --disable-fbo --disable-egl --disable-x11 --disable-sdl --disable-sdl2 --disable-pulse --disable-oss --disable-ffmpeg --disable-freetype --enable-neon --enable-dispmanx --enable-floathard --enable-udev
make
}