summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJulian Xhokaxhiu2015-11-29 01:41:41 +0100
committerJulian Xhokaxhiu2015-11-29 01:41:41 +0100
commitd694cbdef7b080698189646873ec17193bf7e967 (patch)
tree34b7e3dcd540bcff39384141f996b51d7958b03b /PKGBUILD
parentd6a909e486e6875441f41e5a54c2d2b938aefe9a (diff)
downloadaur-d694cbdef7b080698189646873ec17193bf7e967.tar.gz
I hope this is the final fix to the build error...
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD2
1 files changed, 1 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f1fdfb9ab220..76341a327831 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -29,7 +29,7 @@ pkgver() {
build() {
cd "${_gitname}"
export CFLAGS="$CFLAGS -I/opt/vc/include"
- export LDFLAGS="$LDFLAGS -L/opt/vc/lib"
+ export LDFLAGS="${LDFLAGS//-Wl,--as-needed} -L/opt/vc/lib"
./configure --prefix=/usr --disable-vg --disable-opengl --disable-gles --disable-fbo --disable-egl --disable-x11 --disable-sdl --disable-sdl2 --disable-pulse --disable-oss --disable-ffmpeg --enable-neon --enable-dispmanx --enable-floathard --enable-udev
make
}