summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorxiota2023-10-26 00:35:14 -0700
committerxiota2023-10-26 00:36:05 -0700
commit68e773d44e23b1edf2ef5f840d1d2cb39e93f3e5 (patch)
treeb70f64c0ce0e1e2c0850cd54011329134a73dbb1 /PKGBUILD
parent439e6b3c9f48150f7ca2701b95c2a88f51508de1 (diff)
downloadaur-68e773d44e23b1edf2ef5f840d1d2cb39e93f3e5.tar.gz
0.6.7-RC2.r47: pin
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 18 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 85bbdd039647..227fb4546f3e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -29,7 +29,7 @@
## basic info
_pkgname="retroshare"
pkgname="$_pkgname"
-pkgver=0.6.7RC2
+pkgver=0.6.7RC2.r47.gc52e84d70
pkgrel=1
pkgdesc="Serverless encrypted instant messenger with filesharing, chatgroups, e-mail."
#url="http://retroshare.cc/"
@@ -80,13 +80,15 @@ fi
# package type
if [ x"$pkgname" == x"$_pkgname" ] ; then
# normal package
- _pkgver="${pkgver%%.r*}"
+ _commit='c52e84d709df9d264d8aa2b9de41af5825496450'
+
_pkgsrc="$_pkgname"
- source=("$_pkgsrc"::"git+$url.git#tag=v${_pkgver/RC/-RC}")
+ source=("$_pkgsrc"::"git+$url.git#commit=$_commit")
sha256sums=('SKIP')
pkgver() {
- echo ${_pkgver:?}
+ cd "$_pkgsrc"
+ git describe --tags --exclude='*[a-z][a-z]*' | sed -E 's/^v//;s/([^-]*-g)/r\1/;s/-/./g ; s/\.RC/RC/'
}
else
# git package
@@ -100,7 +102,7 @@ else
pkgver() {
cd "$_pkgsrc"
- git describe --long --tags --exclude='*[a-z][a-z]*' | sed -E 's/^v//;s/([^-]*-g)/r\1/;s/-/./g'
+ git describe --long --tags --exclude='*[a-z][a-z]*' | sed -E 's/^v//;s/([^-]*-g)/r\1/;s/-/./g ; s/\.RC/RC/'
}
fi
@@ -117,13 +119,14 @@ source+=(
'libbitdht'::'git+https://github.com/RetroShare/BitDHT.git'
'libretroshare'::'git+https://github.com/RetroShare/libretroshare.git'
'openpgpsdk'::'git+https://github.com/RetroShare/OpenPGP-SDK.git'
+ 'retroshare-webui'::'git+https://github.com/RetroShare/RSNewWebUI.git'
# submodules for rapidjson
'gtest'::'git+https://github.com/google/googletest.git'
# submodules for restbed
- 'catch'::'git+https://github.com/corvusoft/catch-dependency.git'
'asio'::'git+https://github.com/corvusoft/asio-dependency.git'
+ 'catch'::'git+https://github.com/corvusoft/catch-dependency.git'
'openssl'::'git+https://github.com/corvusoft/openssl-dependency.git'
)
@@ -139,6 +142,7 @@ sha256sums+=(
'SKIP'
'SKIP'
'SKIP'
+ 'SKIP'
'SKIP'
@@ -163,6 +167,7 @@ prepare() {
['libbitdht']='libbitdht'
['libretroshare']='libretroshare'
['openpgpsdk']='openpgpsdk'
+ ['retroshare-webui']='retroshare-webui'
)
for key in ${!_submodules[@]} ; do
git submodule init "${_submodules[${key}]}"
@@ -186,8 +191,8 @@ prepare() {
# submodules for restbed
cd "supportlibs/restbed"
local -A _submodules=(
- ['catch']='dependency/catch'
['asio']='dependency/asio'
+ ['catch']='dependency/catch'
['openssl']='dependency/openssl'
)
for key in ${!_submodules[@]} ; do
@@ -202,9 +207,12 @@ build() {
cd "$_pkgsrc"
# remove unwanted plugins
- [[ "$_plugin_voip" != 'true' ]] && sed -i '/VOIP \\/d' plugins/plugins.pro
- [[ "$_plugin_feedreader" != 'true' ]] && sed -i '/FeedReader/d' plugins/plugins.pro
-
+ if [[ ! "${_plugin_voip::1}" =~ 't|y|!' ]] ; then
+ sed -i '/VOIP \\/d' plugins/plugins.pro
+ fi
+ if [[ ! "$_plugin_feedreader" =~ 't|y|1' ]] ; then
+ sed -i '/FeedReader/d' plugins/plugins.pro
+ fi
local _qmake_options=(
CONFIG-=debug