summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorsehraf2015-08-06 08:42:02 +0200
committersehraf2016-02-05 16:22:27 +0100
commit72171bde966a5bd3bf44c57d9a45c9bf785c3550 (patch)
treea3486458dc5cc34928adee89b23882426c03cb9b /PKGBUILD
parentc918bc96c38a4b0b1c74b4aa9a371705c719e4e8 (diff)
downloadaur-72171bde966a5bd3bf44c57d9a45c9bf785c3550.tar.gz
RC3+qt5
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD168
1 files changed, 41 insertions, 127 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9b46971a90c4..6c84710b1c4c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,9 +4,6 @@
# Contributor: Tristero <tristero at online dot de>
# Contributor: funkyou
-# Set this to true to build and install retroshare-nogui
-_build_nogui=true
-
# Set this to true to build and install the plugins
_build_feedreader=true
_build_voip=true
@@ -14,151 +11,68 @@ _build_voip=true
### Nothing to be changed below this line ###
pkgname=retroshare
-pkgver=0.6.0.RC2
-pkgrel=5
+pkgver=0.6.0.RC3
+pkgrel=1
pkgdesc="Serverless encrypted instant messenger with filesharing, chatgroups, e-mail."
arch=('i686' 'x86_64' 'armv6h' 'armv7h')
url="http://retroshare.sourceforge.net/"
license=('GPL' 'LGPL')
-depends=('qt4' 'libupnp' 'libgnome-keyring' 'libxss' 'libmicrohttpd' 'sqlcipher')
-provides=('retroshare')
-conflicts=('retroshare')
+# qt4
+#depends=('qt4' 'libupnp' 'libgnome-keyring' 'libxss' 'libmicrohttpd' 'sqlcipher')
+#makedepends=('git')
+
+#qt 5
+depends=('qt5-multimedia' 'qt5-x11extras' 'libupnp' 'libgnome-keyring' 'libxss' 'libmicrohttpd' 'sqlcipher')
+makedepends=('git' 'qt5-tools')
+
+optdepends=('tor: tor hidden node support'
+ 'i2p: i2p hidden node support')
+provides=("${pkgname}")
+conflicts=("${pkgname}")
install="${pkgname}.install"
-source=(#http://sourceforge.net/projects/retroshare/files/RetroShare/${pkgver}/retroshare_0.6.0.RC2~8551.tar.gz \
- http://downloads.sourceforge.net/project/retroshare/RetroShare/0.6.0-rc2/retroshare_0.6.0.RC2~8551_src.tgz \
- ${pkgname}.install \
- ${pkgname}.desktop)
+source=("https://github.com/RetroShare/RetroShare/archive/v${pkgver}.tar.gz"
+ 'retroshare.install')
-sha256sums=('2320676da905de6c48b01eda611811965277ffa1d5ddbb387aa8f0414c2de050'
- '4b50547648612e9091536205402a4da9ddea9c18c0f71e5d6cd30b2226f206d9'
- '70be00968f2477e368f75393f193e76f366fff2dadab869c855e92048060cf29')
+sha256sums=('c0c3998e3f0a1c7893926cd1c7cc51c26fb03c05648f5c089a4e3d68ae3870a9'
+ '44ea7d8b0208e8954391184dcbb8ff94b2efc246580057a1d2b2e73ad262aad2')
# Add missing dependencies if needed
-[[ $_build_voip == true ]] && depends=(${depends[@]} 'speex' 'opencv')
+[[ $_build_voip == true ]] && depends=(${depends[@]} 'ffmpeg' 'opencv')
[[ $_build_feedreader == true ]] && depends=(${depends[@]} 'curl' 'libxslt')
-_rssrcdir="retroshare06-0.6.0/src"
-
build() {
- local _srcdir="${srcdir}/$_rssrcdir"
- local _qmake='qmake-qt4'
-
- msg "Compiling OpenPGP-SDK..."
- cd "${_srcdir}/openpgpsdk/src"
- $_qmake
- make
-
- msg "Compiling libbitdht..."
- cd "${_srcdir}/libbitdht/src"
- $_qmake
- make
-
- msg "Compiling pegmarkdown..."
- cd "${_srcdir}/supportlibs/pegmarkdown"
- $_qmake
- make
+ cd "${srcdir}/RetroShare-${pkgver}"
+ # remove unwanted plugins
+ if [[ "$_build_voip" != 'true' ]] ; then
+ sed -i '/VOIP \\/d' plugins/plugins.pro
+ fi
+ if [[ "$_build_feedreader" != 'true' ]] ; then
+ sed -i '/FeedReader/d' plugins/plugins.pro
+ fi
- msg "Compiling libretroshare..."
- cd "${_srcdir}/libretroshare/src"
- $_qmake
- make
+ # call version scripts
+ cd libretroshare/src
+ LANG=C ./version_detail.sh
+ cd ../..
- msg "Compiling libresapi..."
- cd "${_srcdir}/libresapi/src"
- $_qmake
- make
+ cd retroshare-gui/src
+ LANG=C ./version_detail.sh
+ cd ../..
- # i'm not 100% sure if this step is required
- # it will download/update some JavaScript files
- msg "Updating webui files..."
- cd "${_srcdir}/libresapi/src/webui/"
+ # qt4: qmake-qt4 -r ...
+ qmake "CONFIG-=debug" "CONFIG+=release" \
+ QMAKE_CFLAGS_RELEASE="${CFLAGS}"\
+ QMAKE_CXXFLAGS_RELEASE="${CXXFLAGS}"\
+ RetroShare.pro
make
-
- msg "Compiling retroshare-gui..."
- cd "${_srcdir}/retroshare-gui/src"
- $_qmake
- make
-
- if [[ "$_build_voip" == "true" ]] ; then
- msg "Compiling VOIP plugin..."
- cd "${_srcdir}/plugins/VOIP"
- $_qmake
- make
- fi
-
- if [[ "$_build_feedreader" == "true" ]] ; then
- msg "Compiling FeedReader plugin..."
- cd "${_srcdir}/plugins/FeedReader"
- $_qmake
- make
- fi
-
- if [[ $_build_nogui == "true" ]] ; then
- msg "Compiling retroshare-nogui..."
- cd "${_srcdir}/retroshare-nogui/src"
- $_qmake
- make
- fi
}
package() {
- local _srcdir="${srcdir}/$_rssrcdir"
-
- # --- Install Files ---
-
- msg "Installing files to fakeroot-environment..."
-
- install -D -m 755 \
- "${_srcdir}/retroshare-gui/src/RetroShare" \
- "${pkgdir}/usr/bin/${pkgname}"
-
- if [[ "$_build_nogui" == "true" ]] ; then
- install -D -m 755 \
- "${_srcdir}/retroshare-nogui/src/retroshare-nogui" \
- "${pkgdir}/usr/bin/${pkgname}-nogui"
- fi
-
- # Webui files ( the path is currently hardcoded for the gui )
- install -d -m 655 "${pkgdir}/usr/share/RetroShare06/webui/"
- for _file in $(ls "${_srcdir}/libresapi/src/webfiles/"); do
- install -D -m 644 \
- "${_srcdir}/libresapi/src/webfiles/${_file}" \
- "${pkgdir}/usr/share/RetroShare06/webui/"
- done
-
-
- # Plugins
- if [[ "$_build_voip" == "true" ]] ; then
- install -D -m 755 \
- "${_srcdir}/plugins/VOIP/libVOIP.so" \
- "${pkgdir}/usr/lib/retroshare/extensions6/libVOIP.so"
- fi
- if [[ "$_build_feedreader" == "true" ]] ; then
- install -D -m 755 \
- "${_srcdir}/plugins/FeedReader/libFeedReader.so" \
- "${pkgdir}/usr/lib/retroshare/extensions6/libFeedReader.so"
- fi
-
- # Icons
- install -D -m 644 \
- "${_srcdir}/retroshare-gui/src/gui/images/logo/logo_512.png" \
- "${pkgdir}/usr/share/pixmaps/retroshare.png"
-
- # Desktop File
- install -D -m 644 \
- "${srcdir}/${pkgname}.desktop" \
- "${pkgdir}/usr/share/applications/${pkgname}.desktop"
-
- # bdboot (needed to bootstrap the DHT)
- install -D -m 644 \
- "${_srcdir}/libbitdht/src/bitdht/bdboot.txt" \
- "${pkgdir}/usr/share/RetroShare06/bdboot.txt"
+ cd "${srcdir}/RetroShare-${pkgver}"
- # Skins
- cp -r "${_srcdir}/retroshare-gui/src/qss" "${pkgdir}/usr/share/RetroShare06/"
- #find "${pkgdir}/usr/share/RetroShare/" -depth -type d -name ".svn" -exec rm -r {} \;
+ make INSTALL_ROOT="${pkgdir}" install
}