summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorsehraf2022-11-03 20:05:27 +0100
committersehraf2022-11-03 20:05:27 +0100
commitf460775ed22e9d58f0304c80b9b30d7dbcb66cb5 (patch)
treeb495f2747e526ea0173747827c5e28f4b885e56c /PKGBUILD
parent8e0aeb968ee9131f3775703ff777d7caa72e7550 (diff)
downloadaur-retroshare-git.tar.gz
fix git situation
based on https://bbs.archlinux.org/viewtopic.php?pid=2063104#p2063104
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3c00c2a7a20a..ff089af9e536 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -28,7 +28,7 @@ _nativ_dialogs='true'
_pkgname=retroshare
pkgname=${_pkgname}-git
-pkgver=v0.6.6.r478.gf5ee9c92c
+pkgver=v0.6.6.r573.g1474dfdd6
pkgrel=1
pkgdesc="Serverless encrypted instant messenger with filesharing, chatgroups, e-mail."
arch=('i686' 'x86_64' 'armv6h' 'armv7h' 'aarch64')
@@ -91,7 +91,7 @@ prepare() {
git config submodule.libbitdht.url "$srcdir/libbitdht"
git config submodule.libretroshare.url "$srcdir/libretroshare"
git config submodule.openpgpsdk.url "$srcdir/openpgpsdk"
- git submodule update
+ git -c protocol.file.allow=always submodule update
}
build() {
@@ -109,6 +109,7 @@ build() {
${_optJsonapi} ${_optAutol} ${_optClang} \
${_optNativDialogs} \
${_optPlugin} ${_optWiki} \
+ CONFIG+=no_rs_friendserver \
QMAKE_CFLAGS_RELEASE="${CFLAGS}" \
QMAKE_CXXFLAGS_RELEASE="${CXXFLAGS}" \
RetroShare.pro