summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorsehraf2018-06-09 12:14:25 +0200
committersehraf2018-06-09 12:14:25 +0200
commit953cac68dbd40d1de6eeb38c164c1e44cdf3b489 (patch)
tree905658eb02345fa2d50256e6c27622f6057cb7a7 /PKGBUILD
parent654784dffa7b5cbfd968030c237864cce42f3509 (diff)
downloadaur-953cac68dbd40d1de6eeb38c164c1e44cdf3b489.tar.gz
add wiki (experimental)
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 7 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b8d44d9c89e0..4e3b07c0eb31 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,6 +8,9 @@
# Set this to 'true' to enable auto login
#_autologin='true'
+# Set this to 'true' to enable wiki functionality (experimental)
+#_wiki='true'
+
# Set this to 'true' to use clang for compiling (experimental)
#_clang='true'
@@ -18,7 +21,7 @@
_pkgname=retroshare
pkgname=${_pkgname}-git
-pkgver=v0.6.4.r114.g135263180
+pkgver=v0.6.4.r173.g5953e7bbe
pkgrel=1
pkgdesc="Serverless encrypted instant messenger with filesharing, chatgroups, e-mail."
arch=('i686' 'x86_64' 'armv6h' 'armv7h')
@@ -44,9 +47,11 @@ sha256sums=('SKIP')
_optClang=''
_optAutol=''
_optPlugin=''
+_optWiki=''
[[ "$_clang" == 'true' ]] && _optClang='-spec linux-clang CONFIG+=c++11'
[[ "$_autologin" == 'true' ]] && _optAutol='CONFIG+=rs_autologin'
([[ "$_plugin_voip" == 'true' ]] || [[ "$_plugin_feedreader" == 'true' ]] || [[ "$_plugin_lua4rs" == 'true' ]]) && _optPlugin='CONFIG+=retroshare_plugins'
+[[ "$_wiki" == 'true' ]] && _optWiki='CONFIG+=wikipoos'
# Handle unofficial plugins
if [[ "$_plugin_lua4rs" == 'true' ]] ; then
@@ -84,7 +89,7 @@ build() {
cd ../..
qmake CONFIG-=debug CONFIG+=release \
- ${_optAutol} ${_optClang} ${_optPlugin} \
+ ${_optAutol} ${_optClang} ${_optPlugin} ${_optWiki} \
QMAKE_CFLAGS_RELEASE="${CFLAGS}" \
QMAKE_CXXFLAGS_RELEASE="${CXXFLAGS}" \
RetroShare.pro