summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFanch2016-11-12 21:12:14 +0100
committerFanch2016-11-12 21:12:14 +0100
commitdb2eb1c2cc38047abcd841ff85a1d56e21c61b07 (patch)
tree7f75572220ea43e6a3fd6950bc3707d079fd0204 /PKGBUILD
parent915c16ba354f7a8634ef09323a9b523124ee2e2f (diff)
downloadaur-db2eb1c2cc38047abcd841ff85a1d56e21c61b07.tar.gz
Update Version
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD46
1 files changed, 26 insertions, 20 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 32b2d73a301c..04573df11169 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,38 +1,42 @@
# Maintainer: sehraf
# Contributor: stqn
-# Mod Fanch
+# custom : fanch
-ncpu=$(grep processor /proc/cpuinfo|wc -l)
-make_option="-j${ncpu}"
+# Set this to 'true' to build and install the plugins
+_build_feedreader=false
+_build_voip=false
+
+# set this to 'true' to use clang for compiling (experimental)
+_clang=
### Nothing to be changed below this line ###
_pkgname=retroshare
pkgname=${_pkgname}-git-no-sqlcipher
-pkgver=0.6.1.r191.g0e1fad0
+pkgver=0.6.1.r299.g1773803
pkgrel=1
pkgdesc="Serverless encrypted instant messenger with filesharing, chatgroups, e-mail."
arch=('i686' 'x86_64' 'armv6h' 'armv7h')
url="http://retroshare.sourceforge.net/"
license=('GPL' 'LGPL')
-
-#qt 5
-depends=('qt5-multimedia' 'qt5-x11extras' 'libupnp' 'libgnome-keyring' 'libxss' 'libmicrohttpd' 'sqlite')
+depends=('qt5-multimedia' 'qt5-x11extras' 'libupnp' 'libgnome-keyring' 'libxss' 'libmicrohttpd')
makedepends=('git' 'qt5-tools')
-
optdepends=('tor: tor hidden node support'
'i2p: i2p hidden node support')
provides=("${_pkgname}")
conflicts=("${_pkgname}")
-install="${_pkgname}.install"
+source=("${_pkgname}::git+https://github.com/RetroShare/RetroShare.git")
+sha256sums=('SKIP')
-source=("${_pkgname}::git+https://github.com/RetroShare/RetroShare.git"
- 'retroshare.install')
-
-sha256sums=('SKIP'
- '44ea7d8b0208e8954391184dcbb8ff94b2efc246580057a1d2b2e73ad262aad2')
+# Add missing dependencies if needed
+[[ "$_build_voip" == 'true' ]] && depends=(${depends[@]} 'ffmpeg' 'opencv')
+[[ "$_build_feedreader" == 'true' ]] && depends=(${depends[@]} 'curl' 'libxslt')
+[[ "$_clang" == 'true' ]] && makedepends=(${makedepends[@]} 'clang')
+# Set options for qmake
+_options='CONFIG+=no_sqlcipher'
+[[ "$_clang" == 'true' ]] && _options='-spec linux-clang CONFIG+=c++11'
pkgver() {
cd "${srcdir}/${_pkgname}"
@@ -43,8 +47,8 @@ build() {
cd "${srcdir}/${_pkgname}"
# remove unwanted plugins
- sed -i '/VOIP \\/d' plugins/plugins.pro
- sed -i '/FeedReader/d' plugins/plugins.pro
+ [[ "$_build_voip" != 'true' ]] && sed -i '/VOIP \\/d' plugins/plugins.pro
+ [[ "$_build_feedreader" != 'true' ]] && sed -i '/FeedReader/d' plugins/plugins.pro
# call version scripts
cd libretroshare/src
@@ -55,10 +59,12 @@ build() {
LANG=C ./version_detail.sh
cd ../..
-
- export LANG=C
- qmake "DEFINES+=NO_SQLCIPHER" "CONFIG+=NO_SQLCIPHER" "CONFIG-=debug" "CONFIG+=release" QMAKE_CFLAGS_RELEASE="${CFLAGS}" QMAKE_CXXFLAGS_RELEASE="${CXXFLAGS}" RetroShare.pro
- make "${make_option}"
+ qmake CONFIG-=debug CONFIG+=release \
+ ${_options} \
+ QMAKE_CFLAGS_RELEASE="${CFLAGS}"\
+ QMAKE_CXXFLAGS_RELEASE="${CXXFLAGS}"\
+ RetroShare.pro
+ make
}
package() {