summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFanch2017-03-09 17:17:32 +0100
committerFanch2017-03-09 17:17:32 +0100
commitffb711ce6d5cb277fb0aa34c20432bfaba0acc89 (patch)
treeb14e5ac7d93619ebbec5db558cd5e2d779f8f251 /PKGBUILD
parent988ede0a145b733e6cfded4d0fcfb35b76744faa (diff)
downloadaur-ffb711ce6d5cb277fb0aa34c20432bfaba0acc89.tar.gz
Update Version
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 15 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 74b3bc18c142..c6a1b1f2e625 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,23 +3,26 @@
# custom : fanch
# Set this to 'true' to build and install the plugins
-_build_feedreader=false
-_build_voip=false
+_build_feedreader=true
+_build_voip=true
+
+# Set this to 'true' to enable auto login
+#_autologin='true'
# set this to 'true' to use clang for compiling (experimental)
-_clang=
+#_clang='true'
### Nothing to be changed below this line ###
_pkgname=retroshare
pkgname=${_pkgname}-git-no-sqlcipher
-pkgver=0.6.1.r613.g753ebdd52
+pkgver=v0.6.2.RC1.r48.ge6cf628fb
pkgrel=1
pkgdesc="Serverless encrypted instant messenger with filesharing, chatgroups, e-mail."
arch=('i686' 'x86_64' 'armv6h' 'armv7h')
url="http://retroshare.sourceforge.net/"
license=('GPL' 'LGPL')
-depends=('qt5-multimedia' 'qt5-x11extras' 'libupnp' 'libgnome-keyring' 'libxss' 'libmicrohttpd')
+depends=('qt5-multimedia' 'qt5-x11extras' 'libupnp' 'libxss' 'libmicrohttpd' 'sqlite')
makedepends=('git' 'qt5-tools')
optdepends=('tor: tor hidden node support'
'i2p: i2p hidden node support')
@@ -33,10 +36,14 @@ sha256sums=('SKIP')
[[ "$_build_voip" == 'true' ]] && depends=(${depends[@]} 'ffmpeg' 'opencv')
[[ "$_build_feedreader" == 'true' ]] && depends=(${depends[@]} 'curl' 'libxslt')
[[ "$_clang" == 'true' ]] && makedepends=(${makedepends[@]} 'clang')
+[[ "$_autologin" == 'true' ]] && depends=(${depends[@]} 'libgnome-keyring')
# Set options for qmake
_options='CONFIG+=no_sqlcipher'
-[[ "$_clang" == 'true' ]] && _options='-spec linux-clang CONFIG+=c++11'
+_optClang=''
+_optAutol=''
+[[ "$_clang" == 'true' ]] && _optClang='-spec linux-clang CONFIG+=c++11'
+[[ "$_autologin" == 'true' ]] && _optAutol='CONFIG+=rs_autologin'
pkgver() {
cd "${srcdir}/${_pkgname}"
@@ -61,6 +68,8 @@ build() {
qmake CONFIG-=debug CONFIG+=release \
${_options} \
+ CONFIG+=rs_nodeprecatedwarning \
+ ${_optAutol} ${_optClang} \
QMAKE_CFLAGS_RELEASE="${CFLAGS}"\
QMAKE_CXXFLAGS_RELEASE="${CXXFLAGS}"\
RetroShare.pro