summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPierre Choffet2022-02-03 12:06:13 -0500
committerPierre Choffet2022-02-03 12:06:13 -0500
commit2a9900052e24f847e646d461c8885210effb83ca (patch)
treebd1f6d609cc5b9af1a153f9d58c43e3f322a41a8 /PKGBUILD
parent554c16387f5f12e192bd32babbfaed2287f4f462 (diff)
downloadaur-2a9900052e24f847e646d461c8885210effb83ca.tar.gz
Change package versioning scheme
Build error reported by saloucious, thank you.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 17 insertions, 17 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1730165bdb71..a4d9b7977487 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Pierre Choffet <peuc@wanadoo.fr>
pkgname=return-to-the-roots-git
-pkgver=r5113.85a6b9941
+pkgver=v0.9.1.120.g83c6f815c
pkgrel=1
pkgdesc="Free/libre implementation of The Settlers II game engine"
arch=("x86_64")
@@ -28,25 +28,25 @@ source=("git+https://github.com/Return-To-The-Roots/s25client.git"
"git+https://github.com/Return-To-The-Roots/version.git"
"git+https://github.com/mat007/turtle.git"
"rttr.sh" "return-to-the-roots.install")
-sha256sums=("SKIP"
- "SKIP"
- "SKIP"
- "SKIP"
- "SKIP"
- "SKIP"
- "SKIP"
- "SKIP"
- "SKIP"
- "SKIP"
- "SKIP"
- "SKIP"
- "SKIP"
- "b623d74292ca332b65290f15adb0c41994a80eb4f5d247c713a0d43775f9e8f8"
- "888a1cd55350971ec3660de79c82760be63ed40617e8ef6931c20b07bc73e1a9")
+sha256sums=('SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'b623d74292ca332b65290f15adb0c41994a80eb4f5d247c713a0d43775f9e8f8'
+ '888a1cd55350971ec3660de79c82760be63ed40617e8ef6931c20b07bc73e1a9')
pkgver() {
cd "s25client/"
- echo "r$(git rev-list --count HEAD).$(git describe --always)"
+ git describe --long | sed 's/-/./g'
}
prepare() {