summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAutumn Boyhan2021-10-18 08:59:00 -0400
committerAutumn Boyhan2021-10-18 08:59:00 -0400
commit7ed684cc7b3f1e1b30f58ac3fa1a4679de116493 (patch)
tree47691d37669f1f87183536e54579057ed71b0b02 /PKGBUILD
parent85e1ac98dfe34d5c4da43603db5883453b0f4089 (diff)
downloadaur-7ed684cc7b3f1e1b30f58ac3fa1a4679de116493.tar.gz
Reworked package to pull in sge and xsge from the aur, hopefully fixing issues with the previous package.
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c792ffea5fbb..3f8afe44a1f9 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,15 @@
pkgname=retux
pkgver=1.6
-pkgrel=1
+pkgrel=2
pkgdesc="ReTux is a libre open source action platformer loosely inspired by the Mario games, utilizing the art assets from the SuperTux project."
arch=('x86_64')
url="https://retux-game.github.io/"
license=('GPL3')
-depends=('python' 'python-pip' 'python-pygame')
+depends=('python' 'python-sge' 'python-xsge')
provides=('retux')
conflicts=('retux' 'retux-bin')
+_name=${pkgname#python-}
source=("https://github.com/retux-game/retux/releases/download/v${pkgver}/${pkgname}-${pkgver}-src.zip"
"${pkgname}.desktop"
"${pkgname}.sh")
@@ -22,7 +23,6 @@ noextract=("${pkgname}-${pkgver}-src.zip")
prepare() {
unzip ${srcdir}/${pkgname}-${pkgver}-src.zip
mv ${srcdir}/${pkgname}-${pkgver}-src ${srcdir}/${pkgname}
- pip install -U uniseg sge xsge_gui xsge_lighting xsge_path xsge_physics xsge_tiled
}
package() {