summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMegumi_fox2022-03-27 22:59:15 +0800
committerMegumi_fox2022-03-27 22:59:15 +0800
commit7260130b75aaf263d953aa763fa8f5d7447cf381 (patch)
treef863d3137e4af25afd56741575b913f0abba11dd /PKGBUILD
downloadaur-7260130b75aaf263d953aa763fa8f5d7447cf381.tar.gz
add pkg revda-git
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD53
1 files changed, 53 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bf3b60c64ab2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,53 @@
+# Maintainer: Megumi_fox <i@megumifox.com>
+
+pkgname=revda-git
+pkgver=5.0.0.r2.g6c067e4
+pkgrel=1
+pkgdesc='Cute and useful Live Stream Player with danmaku support.'
+arch=('x86_64')
+url="https://github.com/THMonster/Revda"
+license=('GPL2')
+provides=('revda' 'qliveplayer-git')
+conflicts=('revda' 'qliveplayer-git')
+replaces=('qliveplayer-git')
+depends=('mpv'
+ 'ffmpeg'
+ 'curl'
+ 'webkit2gtk')
+makedepends=('cmake'
+ 'git'
+ 'rust'
+ 'ninja'
+ 'yarn'
+ 'extra-cmake-modules')
+optdepends=('nodejs: for douyu support')
+source=(
+ "Revda::git+https://github.com/THMonster/Revda.git"
+ "dmlive::git+https://github.com/THMonster/dmlive.git"
+)
+sha256sums=('SKIP' 'SKIP')
+
+pkgver(){
+ cd Revda
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ cd Revda
+ git submodule init
+ git config submodule.src/dmlive.url "$srcdir/dmlive"
+ git submodule update
+}
+
+build() {
+ cd $srcdir/Revda
+ mkdir -p build
+ cd build
+ cmake -GNinja -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release ..
+ ninja
+}
+
+package() {
+ cd $srcdir/Revda/build
+ DESTDIR="$pkgdir" ninja install
+}