summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorburdoto2023-05-07 18:10:44 +0200
committerburdoto2023-05-07 18:10:44 +0200
commit9775b5e8cc1cc433293b4fe76976b59d81ca97fc (patch)
tree81c5e03ddadceb060a60e876a660c3453bd9d3b3 /PKGBUILD
downloadaur-9775b5e8cc1cc433293b4fe76976b59d81ca97fc.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c4ff5e04bc87
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Tobias Burdow <kaleidox@comroid.org>
+
+pkgname=rgx-git
+pkgver=0.1
+pkgrel=1
+pkgdesc="A description of your package"
+arch=('any')
+url="https://github.com/comroid-git/rgx"
+license=('MIT')
+depends=('dotnet-runtime-6.0')
+makedepends=('dotnet-sdk-6.0')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/comroid-git/rgx/archive/v$pkgver.tar.gz")
+
+build() {
+ cd "$srcdir"
+ dotnet build -c Release
+}
+
+package() {
+ cd "$srcdir"
+ install -Dm755 bin/Release/net6.0/rgx "$pkgdir/usr/bin/rgx"
+}