summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorErnesto Bazzano2021-05-09 23:26:27 -0300
committerErnesto Bazzano2021-05-09 23:26:27 -0300
commit95f7f92f1e84274c5a2d871d66403454b08a19c6 (patch)
tree3229bf277f19a40ffb76e9b3041b19c1f1a09f90 /PKGBUILD
downloadaur-95f7f92f1e84274c5a2d871d66403454b08a19c6.tar.gz
init
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bb7fdba42240
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+#Maintainer: Bazza <bazza@riseup.net>
+
+pkgname=('rhubarb-lip-sync')
+pkgver=1.10.1
+pkgrel=1
+pkgdesc="Rhubarb Lip Sync is a command-line tool that automatically creates 2D mouth animation from voice recordings."
+provides=("DanielSWolf")
+makedepends=('cmake' 'boost-libs')
+url='https://github.com/DanielSWolf/rhubarb-lip-sync'
+arch=('x86_64')
+source=("v${pkgver}.zip::https://codeload.github.com/DanielSWolf/rhubarb-lip-sync/zip/refs/heads/master")
+md5sums=('SKIP')
+license=('MIT')
+options=(!strip)
+
+prepare(){
+ pwd
+ cd ${pkgname}-master #${pkgver}
+ pwd
+ mkdir build
+ cd build
+ cmake ..
+ make rhubarb
+}
+
+package(){
+ mkdir -p "${pkgdir}"/usr/bin/
+ cp "${srcdir}"/${pkgname}-master/build/rhubarb/rhubarb "${pkgdir}"/usr/bin/
+ chmod 755 "${pkgdir}"/usr/bin/rhubarb
+}