summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAroun2020-09-10 22:52:43 +0200
committerAroun2020-09-10 22:52:43 +0200
commit947e188fe154755af1cfaf4edcb0245a862c6a0b (patch)
tree2ea0e4bee8a5fc8f0b878ec34454083309029c18 /PKGBUILD
downloadaur-947e188fe154755af1cfaf4edcb0245a862c6a0b.tar.gz
first commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..96ec5f5acd42
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Aroun <login att b-vo dott fr>
+
+pkgname=rhythmbox-plugin-open-containing-folder
+_pkgname=rhythmbox-plugins-open-containing-folder
+_name=OpenContainingFolder
+pkgver=41
+pkgrel=1
+pkgdesc='Adds an option to open the folder containing the selected track(s) to the right click context menu of rhythmbox music player'
+arch=('any')
+url="https://github.com/donaghhorgan/rhythmbox-plugins-open-containing-folder"
+license=(GPL3)
+depends=(
+ rhythmbox
+ xdg-utils
+)
+makedepends=(
+ git
+)
+provides=(
+ rhythmbox-plugin-open-containing-folder
+)
+conflicts=(
+ rhythmbox-plugin-open-containing-folder
+)
+source=("git+${url}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ printf "%s" "$(git rev-list --count HEAD)"
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}"
+ files=( LICENSE $_name.plugin $_name.py README.md )
+ for file in "${files[@]}"
+ do
+ install -Dm644 $file "${pkgdir}/usr/lib/rhythmbox/plugins/${ name}/$file"
+ done
+}
+