summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAngelo Theodorou2022-02-22 15:50:31 +0100
committerAngelo Theodorou2022-02-22 15:53:03 +0100
commit8fe24fff34cecb188cb8f67e1c7e74d4814f0c93 (patch)
treed20ef227d8a30c70cedfa614e6710a665fd610c5 /PKGBUILD
parentb336d4121b21f63904ef249d6aee9c26620d4518 (diff)
downloadaur-ri-li.tar.gz
Add more compilation fixes from Michaël Lhomme
- Change the changelog entry in the PKGBUILD file - Rename the iostream patch file - Join the two changelog text files
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 5 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bafacaf13dbe..fcd04e1a10c0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,21 @@
# Contributor: Angelo Theodorou <encelo@users.sourceforge.net>
pkgname=ri-li
pkgver=2.0.1
-pkgrel=4
+pkgrel=5
pkgdesc="Drive a toy wood engine in many levels and collect all the coaches to win"
arch=('i686' 'x86_64')
url="http://ri-li.sourceforge.net/"
license=('GPL')
depends=('gcc-libs' 'sdl_mixer')
-changelog=('ri-li.changelog')
-source=(http://downloads.sourceforge.net/sourceforge/$pkgname/Ri-li-$pkgver.tar.bz2 ri-li.desktop iostream.patch)
-md5sums=('57a2ff50a0c704786da8adf61d78bf52' 'ff57f8b04b212af3e6f8c600c3e0c35b'
- 'd953710f48bccf1f4de2f7d316c725fe')
+changelog='ri-li.changelog'
+source=(http://downloads.sourceforge.net/sourceforge/$pkgname/Ri-li-$pkgver.tar.bz2 ri-li.desktop fix_compilation.patch)
+md5sums=('57a2ff50a0c704786da8adf61d78bf52' 'ff57f8b04b212af3e6f8c600c3e0c35b' '1736ab476f561a2f7ea809bcef54d0b7')
build() {
cd $srcdir/Ri-li-$pkgver
./configure --prefix=/usr
sed -i "s/SUBDIRS = src data Sounds gentoo/SUBDIRS = src data Sounds/" Makefile
- patch -p1 < $srcdir/iostream.patch
+ patch -p1 < $srcdir/fix_compilation.patch
make || return 1
}