summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAngelo Theodorou2015-08-23 17:06:47 +0100
committerAngelo Theodorou2015-08-23 17:10:54 +0100
commitb336d4121b21f63904ef249d6aee9c26620d4518 (patch)
tree2ae89982aa0998a38a3333836d670999ecc25733 /PKGBUILD
parent2cc62e73f00df816c926381d5050dd1650ce8a2c (diff)
downloadaur-b336d4121b21f63904ef249d6aee9c26620d4518.tar.gz
Add the package() function in the PKGBUILD script
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 6 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0f918d74e6b9..bafacaf13dbe 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,13 @@
# Contributor: Angelo Theodorou <encelo@users.sourceforge.net>
pkgname=ri-li
pkgver=2.0.1
-pkgrel=3
+pkgrel=4
pkgdesc="Drive a toy wood engine in many levels and collect all the coaches to win"
arch=('i686' 'x86_64')
url="http://ri-li.sourceforge.net/"
license=('GPL')
depends=('gcc-libs' 'sdl_mixer')
+changelog=('ri-li.changelog')
source=(http://downloads.sourceforge.net/sourceforge/$pkgname/Ri-li-$pkgver.tar.bz2 ri-li.desktop iostream.patch)
md5sums=('57a2ff50a0c704786da8adf61d78bf52' 'ff57f8b04b212af3e6f8c600c3e0c35b'
'd953710f48bccf1f4de2f7d316c725fe')
@@ -17,6 +18,10 @@ build() {
sed -i "s/SUBDIRS = src data Sounds gentoo/SUBDIRS = src data Sounds/" Makefile
patch -p1 < $srcdir/iostream.patch
make || return 1
+}
+
+package() {
+ cd $srcdir/Ri-li-$pkgver
make DESTDIR=$pkgdir install
install -m644 -D ../ri-li.desktop $pkgdir/usr/share/applications/ri-li.desktop