summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorlastavengers2016-04-10 23:57:17 +0800
committerlastavengers2016-04-10 23:57:17 +0800
commitc9e29a0093eb94050ee5498f5ba755b07b0705b5 (patch)
treea8566283795ab49913f3c8ce08a22d86a2d274a0 /PKGBUILD
downloadaur-c9e29a0093eb94050ee5498f5ba755b07b0705b5.tar.gz
first import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD42
1 files changed, 42 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ef0331efee8d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Yuexuan Gu <lastavengers@outlook.com>
+
+pkgname=ricin
+_pkgname=Ricin
+pkgver=0.0.4.1
+pkgrel=1
+pkgdesc="A dead-simple but powerful Tox client."
+url="https://github.com/RicinApp/Ricin"
+arch=('i686' 'x86_64')
+license=('GPL3')
+makedepends=('git' 'meson-git' 'ninja' 'vala')
+depends=('gtk3'
+ 'toxcore'
+ 'glib2'
+ 'json-glib'
+ 'libsoup'
+ 'libnotify'
+ 'libconfig'
+ )
+
+source=("https://github.com/RicinApp/${_pkgname}/archive/v${pkgver}.tar.gz")
+sha256sums=('ac27f0f02e30262a2e3a87932be3d0ac05be826119b4cec6516c8bf26e366995')
+provides=('ricin')
+conflicts=('ricin')
+
+build() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+
+ make autogen
+ make release
+
+ cd build
+ mesonconf.py -Dprefix=/usr
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+
+ make DESTDIR=$pkgdir install
+ # cover ${pkgdir}/usr/bin/Ricin"
+ install -Dm755 "build/${_pkgname}" "${pkgdir}/usr/bin/ricin"
+}