summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAdrien Prost-Boucle2021-06-24 22:18:53 +0200
committerAdrien Prost-Boucle2021-06-24 22:18:53 +0200
commit711de1095460056de93cfd6f33e7450579dba6bb (patch)
tree84fa6ff0fdecc063c7aa4484ec9084f5dc93fdc5 /PKGBUILD
parent2f797932fb20bd79655f018920296cc5c5b451f7 (diff)
downloadaur-711de1095460056de93cfd6f33e7450579dba6bb.tar.gz
Fix compilation for linux >= 5.12, and switch to sha256sums
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 13 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8f19aa1ff09a..641e38a498fc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Important: the versions of the packages linux and linux-header must match
pkgname=riffa-git
-pkgver=2.2.2.git20170213
+pkgver=2.2.2.git20210624
pkgrel=1
arch=('i686' 'x86_64')
pkgdesc='RIFFA: A Reusable Integration Framework For FPGA Accelerators'
@@ -16,13 +16,15 @@ source=(
#"git://github.com/drichmond/riffa.git"
"git://github.com/marzoul/riffa.git"
'riffa.install'
+ 'patch-subdirs.patch'
'99-riffa.rules'
)
# Note: No check for riffa.install because it is modified by the package() function.
-md5sums=(
+sha256sums=(
'SKIP'
'SKIP'
- 'd37355781ef46d1f4aa21cd169964f08'
+ '102cc4edf8008a193faf15dfe507d8cdb223036de6059b4c8f495b69ead246ac'
+ '6dd2aee2ba41d68419004f7a80b87fbd6a1d8c723d5a2b3d293fe460a7364676'
)
pkgver() {
@@ -36,6 +38,14 @@ pkgver() {
echo $_distver.git$_gitver;
}
+prepare() {
+ cd "${srcdir}/riffa"
+
+ # At least for Linux >= 5.12
+ patch -p0 -N -i ../../patch-subdirs.patch
+
+}
+
build() {
cd "${srcdir}/riffa/driver/linux"