summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPierre Choffet2016-01-07 16:27:18 -0500
committerPierre Choffet2016-01-07 16:27:18 -0500
commitf15bbef4ee4813f179d4c69854f17b736e24bb00 (patch)
tree7a5186b5405fa8313c52bfbd14c7b275e140817e /PKGBUILD
parentc4bfdd13c3f4c395c87bf87abf9e9b171b4a32a6 (diff)
downloadaur-f15bbef4ee4813f179d4c69854f17b736e24bb00.tar.gz
Fix upstream broken build
Upstream ring-kde is broken since libringclient commit 6ea7e56b9f9034bff817451fbebbaf8d1478be3c. Some patches were ready in the next branch but still not in the master. This commit adds them in the package building process. The following commits have been backported: f3f593378d7b26fb8373b2d927156ad7a6f69e19 8cc3ebf5fb9ab3af4d3f991ab93aa94be4203d7a 6926e7714306c5c06d24473954993ee7290c37a5 4a7efcb2fb8cf0bb35f9dac6cc626206ad8116c2 79680670d4376f8f7e0334a0a2d2900b2980f58f Plus some minor modifications have been written in src/CMakeFiles.txt.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 26 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f79243730c59..b49e9bb8b70d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
pkgname=ring-kde-git
pkgver=2.0.0.r138.g18ff797
-pkgrel=1
+pkgrel=2
pkgdesc="KDE client for Ring"
arch=("i686" "x86_64")
url="http://ring.cx/"
@@ -20,8 +20,20 @@ depends=("libringclient-git" "ring-daemon-git" "qt5-base" "qt5-svg"
makedepends=("git" "cmake" "extra-cmake-modules")
provides=("ring-kde")
changelog="ChangeLog"
-source=("git://anongit.kde.org/ring-kde")
-sha256sums=('SKIP')
+source=("git://anongit.kde.org/ring-kde"
+ "0001-textmessages-Vastly-revamp-and-fix-the-text-messages.patch"
+ "0002-contact-Enable-Akonadi-support-again.patch"
+ "0003-history-De-duplicate-identical-calls.patch"
+ "0004-akonadi-Make-it-optional.patch"
+ "0005-Fix-CMakeLists.txt.patch"
+ "0006-contact-Add-new-basic-contact-selection-dialog.patch")
+sha256sums=('SKIP'
+ 'fe1a4a7ba6df920117adf5d57a8fcfaa784986369a50c91bd3ae5b0f69ea2c59'
+ '2fce01531bcdf001b1f8cc34522c5951dcbb853ea597ffa4421cdd78661148d2'
+ '1c1ff7d6244982cbf56720eeda731b5fb09933178e02d0b3d24614a906d91e29'
+ 'b50755d6653b417046734a29d25cdb4ff2cadcc900e119b309e4fbb0d8614894'
+ 'd1215e1ba920f7b359a4319caa6ea286784b32079fc647c2fe7b66a9dde4e44c'
+ 'c22e0d8518575d00dc6b660e5c8979659678e403947526465ceaf17cdca7c517')
pkgver() {
cd "ring-kde"
@@ -29,6 +41,17 @@ pkgver() {
git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
+prepare() {
+ cd "ring-kde"
+
+ git am < '../0001-textmessages-Vastly-revamp-and-fix-the-text-messages.patch'
+ git am < '../0002-contact-Enable-Akonadi-support-again.patch'
+ git am < '../0003-history-De-duplicate-identical-calls.patch'
+ git am < '../0004-akonadi-Make-it-optional.patch'
+ git am < '../0005-Fix-CMakeLists.txt.patch'
+ git am < '../0006-contact-Add-new-basic-contact-selection-dialog.patch'
+}
+
build() {
cd "ring-kde"