summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChris Severance2018-11-29 17:19:42 -0500
committerChris Severance2018-11-29 17:19:42 -0500
commitd0354eec4bfcdaed677c5bbc91e17a44390f9f3d (patch)
treef0cbfefcfada71c282f5772b0def2fa082d2e52f /PKGBUILD
parent22845aa55a14bd55daea1a1f5819055b9caa4ee7 (diff)
downloadaur-riofs-git.tar.gz
autu: Update to 0.6.r86.g40e5396-1 fix arrays
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 10 insertions, 24 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 11b7a3cf355e..80b469807063 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,24 @@
# Maintainer: Chris Severance aur.severach aATt spamgourmet dott com
+# Contributor: dreieck
# Contributor: Gustavo Lopes <mail@geleia.net>
set -u
_pkgname='riofs'
pkgname="${_pkgname}-git"
_srcdir="${pkgname}"
-pkgver=0.6.r47.gc6d8e8e
+pkgver=0.6.r86.g40e5396
pkgrel=1
pkgdesc='FUSE userspace filesystem for Amazon AWS S3 buckets'
arch=('i686' 'x86_64')
url="https://github.com/skoobe/${_pkgname}"
license=('GPL3')
-depends=('fuse' 'glib2' 'libevent' 'libxml2' 'openssl')
+depends=('file' 'fuse' 'glib2' 'libevent' 'libxml2' 'openssl')
makedepends=('pkg-config' 'git')
+provides=("${_pkgname}=${pkgver%.r*}")
+conflicts=("${_pkgname}")
_verwatch=("${url}/releases" "${url#*github.com}/archive/v\(.*\)\.tar\.gz" 'l')
source=("${_srcdir}::git+${url}.git") # #commit=${pkgver##*.g}
sha256sums=('SKIP')
-conflicts="${_pkgname}"
-provides="${_pkgname}=${pkgver%.r*}"
pkgver() {
set -u
@@ -26,18 +27,14 @@ pkgver() {
set +u
}
-prepare() {
- set -u
- cd "${_srcdir}"
- ./autogen.sh
- ./configure --prefix='/usr' --includedir='/usr/include/riofs'
- set +u
-}
-
build() {
set -u
cd "${_srcdir}"
- make -s -j $(nproc)
+ if [ ! -s 'Makefile' ]; then
+ ./autogen.sh
+ ./configure --prefix='/usr' --includedir='/usr/include/riofs'
+ fi
+ make -s
set +u
}
@@ -46,17 +43,6 @@ package() {
cd "${_srcdir}"
make -s DESTDIR="${pkgdir}" install
set +u
- # Ensure there are no forbidden paths. Place at the end of package() and comment out as you find or need exceptions. (git-aurcheck)
- ! test -d "${pkgdir}/bin" || { echo "Line ${LINENO} Forbidden: /bin"; false; }
- ! test -d "${pkgdir}/sbin" || { echo "Line ${LINENO} Forbidden: /sbin"; false; }
- ! test -d "${pkgdir}/lib" || { echo "Line ${LINENO} Forbidden: /lib"; false; }
- ! test -d "${pkgdir}/share" || { echo "Line ${LINENO} Forbidden: /share"; false; }
- ! test -d "${pkgdir}/usr/sbin" || { echo "Line ${LINENO} Forbidden: /usr/sbin"; false; }
- ! test -d "${pkgdir}/usr/local" || { echo "Line ${LINENO} Forbidden: /usr/local"; false; }
- ! grep -lr "/sbin" "${pkgdir}" || { echo "Line ${LINENO} Forbidden: /sbin"; false; }
- ! grep -lr "/usr/tmp" "${pkgdir}" || { echo "Line ${LINENO} Forbidden: /usr/tmp"; false; }
- ! grep -lr "/usr/local" "${pkgdir}" || { echo "Line ${LINENO} Forbidden: /usr/local"; false; }
- ! pcre2grep -Ilr "(?<!/usr)/bin" "${pkgdir}" || { echo "Line ${LINENO} Forbidden: /bin"; false; }
}
set +u