summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMarcel Radzio2017-08-23 19:08:10 +0200
committerMarcel Radzio2017-08-23 19:08:10 +0200
commitfd3bf9925f3ee20c8dbf41bd0b3e8f474200b6a1 (patch)
treeddce863898c0be104bc3fce3e7156e335b93d2a9 /PKGBUILD
parent0e9a4495cb27c2d9de03ef3d113ac38abe0631c1 (diff)
downloadaur-fd3bf9925f3ee20c8dbf41bd0b3e8f474200b6a1.tar.gz
fix build issues and bump version
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 15 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index eecfacc70b0d..ba7bee949e80 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Marcel Radzio <info@nordgedanken.de>
pkgbase=riot-desktop-git
-pkgver=r3963.cf5cf025
-pkgrel=5
+pkgver=r4523.9e57c9d7
+pkgrel=1
pkgname=riot-desktop-git
pkgdesc="A glossy Matrix collaboration client for the desktop."
arch=('any')
@@ -33,7 +33,20 @@ prepare() {
build() {
cd "$srcdir/${pkgname}"
npm install --cache "${srcdir}/npm-cache"
+
+ # Build matrix-js-sdk manualy as npm@5 doesn't trigger the build
+ cd "$srcdir/${pkgname}/node_modules/matrix-js-sdk"
+ npm install --cache "${srcdir}/npm-cache"
+ npm run build --cache "${srcdir}/npm-cache"
+
+ # Build matrix-react-sdk manualy as npm@5 doesn't trigger the build
+ cd "$srcdir/${pkgname}/node_modules/matrix-react-sdk"
+ npm install --cache "${srcdir}/npm-cache"
npm run build --cache "${srcdir}/npm-cache"
+
+
+ cd "$srcdir/${pkgname}"
+ npm run build --cache "${srcdir}/npm-cache"
}
package() {