summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChris Lane2021-10-08 09:16:15 +0100
committerChris Lane2021-10-08 09:16:15 +0100
commit5dfcaa3e4bc7ea20543c297344fc817f8e377039 (patch)
treec1545c7b19fb7e9fb593fac41d40043762d3078c /PKGBUILD
parentacd3a1dfd97330a30ce9409b1eab76714eb51b21 (diff)
downloadaur-ripgrep-all.tar.gz
Update to follow rust packaging guidelines
Also disabled lto since this breaks the build
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 13 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d4955acbd3e7..d6a06d40b47f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,13 +4,13 @@
pkgname=ripgrep-all
pkgver=0.9.6
-pkgrel=1
+pkgrel=2
pkgdesc="rga: ripgrep, but also search in PDFs, E-Books, Office documents, zip, tar.gz, etc."
arch=('i686' 'x86_64' 'armv6h' 'armv7h')
url="https://github.com/phiresky/ripgrep-all"
license=('AGPL3')
depends=('ripgrep')
-makedepends=('rust' 'cargo')
+makedepends=('cargo')
optdepends=(
'ffmpeg: for the ffmpeg adapter'
'graphicsmagick: for the pdfpages adapter'
@@ -20,15 +20,24 @@ optdepends=(
conflicts=("${pkgname}-git" "${pkgname}-bin")
source=("${pkgname}-${pkgver}"::"${url}/archive/v${pkgver}.tar.gz")
sha512sums=('45fc258e8ef44ddd7ce6b4c7dc5c60a439c8e5aafd253ea41621afcc50aaecd300d8792c4cbdc9247a5656d9c3db0a33053de96ca41f0831421ea8ce382ca7de')
+options=(!lto)
+
+prepare() {
+ cd "${srcdir}/ripgrep-all-${pkgver}"
+ cargo fetch --locked --target "$CARCH-unknown-linux-gnu"
+}
build() {
cd "${srcdir}/ripgrep-all-${pkgver}"
- cargo build --release --locked --target-dir=$PWD/target
+ export RUSTUP_TOOLCHAIN=stable
+ export CARGO_TARGET_DIR=target
+ cargo build --frozen --release --all-features
}
check() {
cd "${srcdir}/ripgrep-all-${pkgver}"
- cargo test --release --locked --target-dir=$PWD/target
+ export RUSTUP_TOOLCHAIN=stable
+ cargo test --frozen --all-features
}
package() {