summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorneeshy2019-08-01 04:23:09 -0400
committerneeshy2020-04-02 13:41:56 -0400
commita87466abe6b9d2eac65ceb637983d183ac0d5ea2 (patch)
tree213900ea8af54ffc0fd126751adf1fed5aad5e6f /PKGBUILD
parent2c77c577ad9de77f97e5213f8f48e9e9ed129533 (diff)
downloadaur-a87466abe6b9d2eac65ceb637983d183ac0d5ea2.tar.gz
Add freetype patch and proper dependencies
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 9 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 86cafdd72ce7..b9ef6f2c8f57 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,12 +6,16 @@ pkgdesc="RealLive clone for Linux and OSX. Git version."
arch=(i686 x86_64)
url="http://www.elliotglaysher.org/rlvm/"
license=('GPL')
-depends=('boost-libs>=1.46' glew libmad sdl_mixer sdl_image sdl_ttf guichan)
-makedepends=(scons boost)
+depends=('boost-libs>=1.46' glew libmad sdl_mixer sdl_image sdl_ttf guichan gtk2)
+makedepends=(git scons boost)
provides=(rlvm)
conflicts=(rlvm)
-source=('git+https://github.com/eglaysher/rlvm.git' 'detect_guichan.patch')
-md5sums=('SKIP' 'caf806e9f037ba95a747a0aefde7fd9d')
+source=('git+https://github.com/eglaysher/rlvm.git'
+ 'detect_guichan.patch'
+ 'freetype.patch')
+md5sums=('SKIP'
+ 'caf806e9f037ba95a747a0aefde7fd9d'
+ '60d11c6a9b259eda3ee69c6a6ddaffac')
pkgver() {
cd "$srcdir/rlvm/"
@@ -22,6 +26,7 @@ prepare() {
cd "$srcdir/rlvm/"
rm -r "$srcdir/rlvm/vendor/guichan"
patch -p1 < "$srcdir/detect_guichan.patch"
+ patch -p1 < "$srcdir/freetype.patch"
}
build() {