summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChris P2015-07-19 21:25:57 +0200
committerChris P2015-07-19 21:25:57 +0200
commit15d0259659b9c8296b193bd68630dd2311ebc269 (patch)
tree1e4ed27d6cd8c8525c8c2437ee6dd42a60bb9350 /PKGBUILD
downloadaur-15d0259659b9c8296b193bd68630dd2311ebc269.tar.gz
Initial aur4 push
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1c53cfd01200
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: SahibBommelig <sahib@online.de>
+# rmlint PKBUILD for ArchLinux
+
+_pkgname=rmlint
+pkgname=${_pkgname}-git
+pkgver=967.812a5d5
+pkgrel=3
+pkgdesc="Tool to remove duplicates and other lint, being much faster than fdupes"
+arch=('i686' 'x86_64')
+url="https://github.com/sahib/rmlint"
+license=('GPL3')
+depends=('glibc' 'glib2>=2.31' 'libutil-linux' 'elfutils')
+makedepends=('git' 'scons' 'python-sphinx')
+provides=("$_pkgname")
+source=("$pkgname"::"git+https://github.com/sahib/${_pkgname}.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${pkgname}"
+ printf "%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "${srcdir}/${pkgname}"
+ scons config
+ scons -j4 DEBUG=1 --prefix=${pkgdir}/usr --actual-prefix=/usr
+}
+
+package() {
+ cd "${srcdir}/${pkgname}"
+ scons DEBUG=1 --prefix=${pkgdir}/usr install --actual-prefix=/usr
+}