summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLeo2020-12-28 01:03:36 +0800
committerLeo2020-12-28 01:03:36 +0800
commit5000f04e3fe09611ad3e2b8df453e8ef3af2fece (patch)
tree73a06ea0f2a023d7c93a8227da0e0b7206242932 /PKGBUILD
parent3bd2b5e5b00cdc1acb6fff13ed89797e7a5a8394 (diff)
downloadaur-5000f04e3fe09611ad3e2b8df453e8ef3af2fece.tar.gz
New upstream version 1.9.1
* apply patch for build version and time * rename package and conflicts with the patched version
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 7 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 71034f1fd001..28e02a69d364 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Leo <i@setuid0.dev>
pkgname=roadrunner
-pkgver=1.9.0
+pkgver=1.9.1
pkgrel=1
pkgdesc="High-performance PHP application server, load-balancer and process manager written in Golang"
arch=(x86_64)
@@ -13,14 +13,19 @@ source=(
"https://github.com/spiral/$pkgname/archive/v$pkgver.tar.gz"
".rr.yaml.sample-full"
".rr.yaml.sample-minimal"
+ "02-build_version_time.patch"
)
sha256sums=(
- "ee306cce2132c8f0b0dbd3a085084194f7c8659ae50a87ea06c160d4f2c716c4"
+ "4e11dd50d2d1a645b4eace027ed48c7dcfb8bfaba82100c5476e1a75f6188433"
+ SKIP
SKIP
SKIP
)
options=("!buildflags")
+# Won't allow installing of both patched and original version.
+conflicts=("roadrunner-leo-patched")
+
build() {
export GOPATH="$srcdir"/gopath
export CGO_CPPFLAGS="${CPPFLAGS}"