summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorgéballin2019-01-06 02:53:53 +0100
committergéballin2019-01-06 02:53:53 +0100
commitc00a462e167cc9b60b40edb7898ad14423f803f1 (patch)
tree108677c1c921e65e606f13af9be52f4aa33d4e40 /PKGBUILD
downloadaur-c00a462e167cc9b60b40edb7898ad14423f803f1.tar.gz
Initial commit for Robodoc for AUR
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..62e2f1bdbac7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Geballin - Guillaume Ballin <macniaque at free dot fr>
+pkgname=robodoc
+pkgver=4.99.43
+pkgrel=1
+pkgdesc="ROBODoc is program documentation tool. It works with many programming languages: For instance C, Pascal, Shell Scripts, Assembler, COBOL, Occam, Postscript, Forth, Tcl/Tk, C++, Java -- basically any program in which you can use remarks/comments."
+url="https://rfsber.home.xs4all.nl/Robo/"
+arch=('x86_64' 'i686')
+license=('GPLv3')
+depends=()
+optdepends=()
+makedepends=(gcc make)
+conflicts=()
+replaces=()
+backup=()
+install=
+source=("http://rfsber.home.xs4all.nl/Robo/archives/robodoc-4.99.43.tar.gz")
+
+md5sums=('063e4ba0fbfd6da7ece0acc5d9419e10')
+
+build() {
+ tar xzf robodoc-${pkgver}.tar.gz
+ cd robodoc-${pkgver}
+ ./configure --prefix=/usr
+ make
+ }
+
+package() {
+ cd robodoc-${pkgver}
+ make DESTDIR="${pkgdir}" install
+ }