summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBenjamin Chrétien2013-04-11 11:04:26 +0900
committerBenjamin Chrétien2013-04-11 11:06:28 +0900
commit2074a913268633302351886bf407a3aad4a712ed (patch)
tree98fd3d38aaee76e44d8bad19798d6239774aa8ca /PKGBUILD
downloadaur-2074a913268633302351886bf407a3aad4a712ed.tar.gz
Add roboptim-core (2.0 release)
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD59
1 files changed, 59 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..9ae8591e77e3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,59 @@
+# Maintainer: Benjamin Chretien <chretien@lirmm.fr>
+# Contributor: Thomas Moulard <thomas.moulard@gmail.com>
+pkgname=roboptim-core
+pkgver=2.0
+pkgrel=1
+pkgdesc="Numerical Optimization for Robotics"
+arch=('i686' 'x86_64')
+url="http://roboptim.net/"
+license=('(L)GPL2')
+depends=('eigen3>=3' 'boost>=1.41' 'doxygen' 'libltdl' 'log4cxx')
+optdepends=()
+makedepends=('cmake')
+provides=('roboptim-core')
+conflicts=('roboptim-core-git')
+source=(https://github.com/roboptim/releases/blob/master/${pkgname}/${pkgname}-${pkgver}.tar.gz)
+md5sums=('1d077052fb801a95209407e0661f9a6d')
+
+# Build type
+_buildtype="RELWITHDEBINFO"
+
+# Build the project
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ msg "Starting CMake (build type = ${_buildtype})"
+
+ # Create a build directory
+ mkdir -p "${srcdir}/${pkgname}-${pkgver}-build"
+ cd "${srcdir}/${pkgname}-${pkgver}-build"
+
+ # Run CMake in release
+ cmake -DCMAKE_BUILD_TYPE="${_buildtype}" \
+ -DCMAKE_INSTALL_PREFIX="/usr" \
+ "${srcdir}/${pkgname}-${pkgver}"
+
+ # Compile the library
+ msg "Building the project"
+ make --silent
+
+ # Create the documentation
+ msg "Creating the documentation"
+ make --silent doc
+}
+
+# Run unit tests
+check() {
+ msg "Running unit tests"
+ cd "${srcdir}/${pkgname}-${pkgver}-build"
+ make test
+}
+
+# Create the package
+package() {
+ # Install in /opt/roboptim
+ cd "${srcdir}/${pkgname}-${pkgver}-build"
+
+ msg "Installing files"
+ make --silent DESTDIR="${pkgdir}/" install
+}