summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTorsten Keßler2022-02-12 18:18:57 +0100
committerTorsten Keßler2022-02-12 18:18:57 +0100
commit838fa46e6d3d1b43daa14ce7eed450d3c12fc168 (patch)
treec40166a88ed4f0fe1acbea9c42c445c6c75e0319 /PKGBUILD
parent420e6b8e2f718d71bd68998e18ba331d497d5b55 (diff)
downloadaur-838fa46e6d3d1b43daa14ce7eed450d3c12fc168.tar.gz
upgpkg: rocblas 5.0.0-1
upstream release
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 297694a36c18..26fb561f37d1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Torsten Keßler <t dot kessler at posteo dot de>
# Contributor: Markus Näther <naether.markus@gmail.com>
pkgname=rocblas
-pkgver=4.5.2
+pkgver=5.0.0
pkgrel=1
pkgdesc='Next generation BLAS implementation for ROCm platform'
arch=('x86_64')
@@ -12,14 +12,14 @@ makedepends=('cmake' 'git' 'python' 'python-virtualenv' 'python-pyaml'
'perl-file-which' 'msgpack-c' 'rocm-cmake' 'gcc-fortran')
_rocblas='https://github.com/ROCmSoftwarePlatform/rocBLAS'
source=("$pkgname-$pkgver.tar.gz::$_rocblas/archive/rocm-$pkgver.tar.gz")
-sha256sums=('15d725e38f91d1ff7772c4204b97c1515af58fa7b8ec2a2014b99b6d337909c4')
+sha256sums=('4b01fba937ada774f09c7ccb5e9fdc66e1a5d46c130be833e3706e6b5841b1da')
options=(!strip)
_dirname="$(basename "$_rocblas")-$(basename "${source[0]}" ".tar.gz")"
build() {
# -fcf-protection is not supported by HIP, see
- # https://github.com/ROCm-Developer-Tools/HIP/blob/rocm-4.5.x/docs/markdown/clang_options.md
+ # https://github.com/ROCm-Developer-Tools/HIP/blob/rocm-5.0.x/docs/markdown/clang_options.md
PATH="/opt/rocm/llvm/bin:${PATH}" \
CXX=/opt/rocm/bin/hipcc \
CXXFLAGS="${CXXFLAGS} -fcf-protection=none" \