summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAnthony Wang2022-03-18 04:02:55 -0500
committerGitHub2022-03-18 10:02:55 +0100
commit98eff8b8881bcc42153fa001f90c629618500b06 (patch)
tree9ae98e2999942e20e858f0bb6e9801706d9ccec9 /PKGBUILD
parente53d5d53ecbf75d81e44e30892de3b967abd330d (diff)
downloadaur-98eff8b8881bcc42153fa001f90c629618500b06.tar.gz
Use cmake -DAMDGPU_TARGETS=${AMDGPU_TARGETS} to specify GPU targets (#650)
hip-runtime-amd https://github.com/ROCm-Developer-Tools/hipamd/blob/develop/hip-config.cmake.in#L165 hipcub https://github.com/ROCmSoftwarePlatform/hipCUB/blob/develop/CMakeLists.txt#L62 hipfft https://github.com/ROCmSoftwarePlatform/hipfft/blob/develop/CMakeLists.txt#L108 rccl https://github.com/ROCmSoftwarePlatform/rccl/blob/develop/CMakeLists.txt#L45 rocalution https://github.com/ROCmSoftwarePlatform/rocalution/blob/develop/CMakeLists.txt#L84 rocblas https://github.com/ROCmSoftwarePlatform/rocblas/blob/develop/CMakeLists.txt#L91 rocfft https://github.com/ROCmSoftwarePlatform/rocfft/blob/develop/CMakeLists.txt#L142 rocrand https://github.com/ROCmSoftwarePlatform/rocrand/blob/develop/CMakeLists.txt#L79 rocsolver https://github.com/ROCmSoftwarePlatform/rocsolver/blob/develop/CMakeLists.txt#L128 rocsparse https://github.com/ROCmSoftwarePlatform/rocsparse/blob/develop/CMakeLists.txt#L158 rocthrust https://github.com/ROCmSoftwarePlatform/rocthrust/blob/develop/CMakeLists.txt#L68
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD3
1 files changed, 2 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3ed8e06b8510..4d68aba596d7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -37,7 +37,8 @@ build() {
-DBUILD_CLIENTS_TESTS=OFF \
-DBUILD_CLIENTS_BENCHMARKS=OFF \
-DBUILD_CLIENTS_SAMPLES=OFF \
- -DBUILD_TESTING=OFF
+ -DBUILD_TESTING=OFF \
+ -DAMDGPU_TARGETS=${AMDGPU_TARGETS}
make -C build
}