summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTorsten Keßler2020-09-08 19:00:22 +0200
committerGitHub2020-09-08 13:00:22 -0400
commitac95df886eabb556d6701c44973e27d7fc7bcbf7 (patch)
treeb84bf07d6ae462050dcf130dccc130a4137cacdb /PKGBUILD
parentee79967920b7f5e7a648b48296f0db3cbbe86689 (diff)
downloadaur-ac95df886eabb556d6701c44973e27d7fc7bcbf7.tar.gz
[rocblas] Build Tensile with clang from llvm-amdgpu and enable host libraries (#413)
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7f5ea909e777..ab3fe8ed0010 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Markus Näther <naether.markus@gmail.com>
pkgname=rocblas
pkgver=3.7.0
-pkgrel=1
+pkgrel=2
pkgdesc='Next generation BLAS implementation for ROCm platform'
arch=('x86_64')
url='https://rocblas.readthedocs.io/en/latest'
@@ -19,7 +19,8 @@ build() {
export CFLAGS="$(sed -e 's/-fstack-protector-strong//' <<< "$CFLAGS")"
export CXXFLAGS="$(sed -e 's/-fstack-protector-strong//' <<< "$CXXFLAGS")"
export CPPFLAGS="$(sed -e 's/-fstack-protector-strong//' <<< "$CPPFLAGS")"
-
+
+ PATH="/opt/rocm/llvm/bin:${PATH}" \
CXX=/opt/rocm/hip/bin/hipcc \
cmake -B build -Wno-dev \
-S "$_dirname" \
@@ -27,7 +28,7 @@ build() {
-DCMAKE_PREFIX_PATH=/opt/rocm/llvm/lib/cmake/llvm \
-Damd_comgr_DIR=/opt/rocm/lib/cmake/amd_comgr \
-DBUILD_WITH_TENSILE=ON \
- -DBUILD_WITH_TENSILE_HOST=OFF \
+ -DBUILD_WITH_TENSILE_HOST=ON \
-DTensile_LIBRARY_FORMAT=yaml \
-DTensile_COMPILER=hipcc \
-DTensile_ARCHITECTURE=all \