summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAaron Fischer2015-05-24 22:33:51 +0200
committerAaron Fischer2015-05-24 22:33:51 +0200
commit7e949803ae54de317209374a1fdccd3bd94c7f6a (patch)
treec5867b7b52a95e288c8cc9a3d344c1c0cb815b61 /PKGBUILD
parent2ddb84980b5e9e413fd860992436a94491bebcab (diff)
downloadaur-7e949803ae54de317209374a1fdccd3bd94c7f6a.tar.gz
Fix roccat-tools again
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 10 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bb70a54da619..6b34ea7b22e6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -22,23 +22,29 @@ pkgname=('roccat-tools-common'
'roccat-tools-savu'
'roccat-tools-tyon')
pkgbase=roccat-tools
-pkgver=3.3.0
+pkgver=3.4.0
pkgrel=1
pkgdesc='Userland applications to configure and make extended use of ROCCAT devices'
arch=('i686' 'x86_64')
url='http://roccat.sourceforge.net'
license=('GPL2')
-depends=('libgaminggear=0.8.0' 'libcanberra' 'gtk2' 'libnotify>=0.7.0' 'dbus-glib' 'udev' 'hicolor-icon-theme')
+depends=('libgaminggear=0.9.0' 'libcanberra' 'gtk2' 'libnotify>=0.7.0' 'dbus-glib' 'udev' 'hicolor-icon-theme')
makedepends=('cmake')
optdepends=('kmod-roccat: Adds support for the old kone device.')
conflicts=
-source=("http://downloads.sourceforge.net/project/roccat/roccat-tools/roccat-tools-$pkgver.tar.bz2")
+source=("http://downloads.sourceforge.net/project/roccat/roccat-tools/roccat-tools-$pkgver.tar.bz2"
+ 'udev-compilation-error-fix.patch')
-md5sums=('62c8283c7cd92ee005eebfa7a68e990b')
+md5sums=('3450bb0fb771f33d159ffff7a4860ab6'
+ '414d6306796c659a3adc86ef213e3569')
build() {
cd "$srcdir/$pkgbase-$pkgver"
+ # See here for more detail and progress on this:
+ # https://sourceforge.net/p/roccat/bugs/51/
+ patch -p1 -i ../udev-compilation-error-fix.patch
+
cmake . -DCMAKE_INSTALL_PREFIX=/usr -DUDEVDIR=/usr/lib/udev/rules.d -DWITHOUT_PYTHON=TRUE
make
}