summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorml2020-03-07 02:33:17 +0100
committerml2020-03-07 02:33:17 +0100
commit4311b9a358cefd9bd0a5852ca83a4b7b0d28d44d (patch)
treea2c1997e424074f16505574cfd8bba2173857491 /PKGBUILD
parent5078f0738fe278dcd0641ed119ab877a47dbc902 (diff)
downloadaur-4311b9a358cefd9bd0a5852ca83a4b7b0d28d44d.tar.gz
Hotfix: Go back to electron 7 bloat
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 21 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a1c00d9151d3..d9cde331cb84 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,25 +3,27 @@
pkgname=rocketchat-desktop
pkgver=2.17.7
_srcname="Rocket.Chat.Electron-$pkgver"
-pkgrel=2
+pkgrel=3
pkgdesc='Rocket.Chat Native Cross-Platform Desktop Application via Electron.'
arch=('i686' 'x86_64')
url="https://github.com/RocketChat/Rocket.Chat.Electron"
license=('MIT')
-depends=('electron')
-makedepends=('gulp' 'nodejs' 'node-gyp' 'python' 'yarn')
+#depends=('electron')
+makedepends=('nodejs-lts-erbium' 'node-gyp' 'python' 'yarn')
optdepends=('hunspell-en_US: spell checking')
conflicts=('rocketchat-client-bin')
source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz"
rocketchat-desktop
rocketchat-desktop.desktop
- fix-build.patch
- use-system-dictionaries.patch)
+ no-multiarch-build.patch
+ use-system-dictionaries.patch
+ linux-target-dir.patch)
sha512sums=('49514e0cce8e19f2dee6bfc44777065ae5d557d1cb4c3034988d5e1b13dd6a6b3e444eaec4d52ea647b7d04cbd7b1422eb31b0b8113d2f98ec32c7d5b62ad142'
'1f0f7197012421ff42d2936f73e697e35eef8c57fb9fed59ee022f9d170d6496407f89e426526fba8451fe304b3a8de1724d1cd14bd85d781bbf6aa9ca078d7d'
'd87664b9bdf30eac3011393d094962e0d568a94b5eaf4c8e5f17529442dcba905cea7341527066102a97a07a981acd6ce045b8737eb78a7d81a2a2d05023fe26'
- 'ae924a722734962432c795f051dc35771c0347b655845fcb614c3424674e23aca071708ae0b84b19794b6f532af7a409ca078ff0f60db0ee88a8bcb09f78c1ab'
- '88361c770163c4c1d692128a4c8848d2f9700382394dbbe1391b2d0c22268dee1be850d391eece22ee51d9c119971337884dfd7a4c58c29e384b652592c4df9b')
+ '0fdce645784b9b0ccbe203ecc61f10840514e79748dc10adc98924e34682ce8d8f024aeb03fed318f915ed52cd2abf97da3cae21f4bf45354e08194638a7e34e'
+ '88361c770163c4c1d692128a4c8848d2f9700382394dbbe1391b2d0c22268dee1be850d391eece22ee51d9c119971337884dfd7a4c58c29e384b652592c4df9b'
+ '07a54cc257a1d231b42339f9f1389ad7948e621e11d695498fb6e04f4f1aa07972faf6b34e83aaca94515252c7645d16d7f7da9e59c3d836426222c9e2c2c1fd')
if [[ $CARCH == "i686" ]]; then
_releasename="release:linux-ia32"
_distname="linux-ia32-unpacked"
@@ -31,26 +33,32 @@ else
fi
prepare() {
- for patch in fix-build.patch use-system-dictionaries.patch; do
+ for patch in no-multiarch-build.patch use-system-dictionaries.patch linux-target-dir.patch; do
patch -N -p1 -d "$_srcname" -i "$srcdir/$patch"
done
cd "$_srcname"
- yarn upgrade "electron@$(sed '/^v/ d' /usr/lib/electron/version)" --non-interactive --cache-folder "$srcdir/yarn-cache"
+ yarn install --non-interactive
+ #yarn upgrade "electron@$(sed '/^v/ d' /usr/lib/electron/version)" --non-interactive
}
build() {
cd "$_srcname"
- NODE_ENV=production yarn --cache-folder="$srcdir/yarn-cache" gulp build
- NODE_ENV=production yarn --cache-folder="$srcdir/yarn-cache" gulp "$_releasename"
+ NODE_ENV=production yarn gulp build
+ NODE_ENV=production yarn gulp "$_releasename"
}
package() {
install -Dm644 "$pkgname.desktop" "$pkgdir/usr/share/applications/$pkgname.desktop"
- install -Dm755 "$pkgname" "$pkgdir/usr/bin/$pkgname"
+ #install -Dm755 "$pkgname" "$pkgdir/usr/bin/$pkgname"
cd "$_srcname"
install -Dm644 "build/icons/512x512.png" "$pkgdir/usr/share/icons/hicolor/512x512/apps/$pkgname.png"
install -Dm644 "LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
- install -Dm644 "dist/$_distname/resources/app.asar" "$pkgdir/usr/lib/$pkgname.asar"
+
+ rm -r dist/linux-unpacked/resources/{dictionaries,build}
+ mkdir -m755 "$pkgdir"/{opt,usr/bin}
+ cp -a "dist/linux-unpacked" "$pkgdir/opt/rocketchat-desktop"
+ ln -s /opt/rocketchat-desktop/rocketchat-desktop "$pkgdir/usr/bin/rocketchat-desktop"
+ #install -Dm644 "dist/$_distname/resources/app.asar" "$pkgdir/usr/lib/$pkgname.asar"
}