summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorStephan Springer2023-08-06 18:55:12 +0200
committerStephan Springer2023-08-06 18:55:16 +0200
commit7691a462f7a9e1fec68db23a35920510af4545c4 (patch)
treed27e5b0eaf8d337b813559c145561fe0bf16902c /PKGBUILD
parentec305f207c347a54b5d47692e7986a57029b18d0 (diff)
downloadaur-7691a462f7a9e1fec68db23a35920510af4545c4.tar.gz
update to version 3.9.6 and switch to electron 22
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 8 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bbb8fe1d0049..262c215f6b75 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,22 +4,20 @@
# Contributor: sum01 <sum01@protonmail.com>
pkgname=rocketchat-desktop
-pkgver=3.9.5
+pkgver=3.9.6
pkgrel=1
pkgdesc='Rocket.Chat Native Cross-Platform Desktop Application via Electron'
arch=('any')
url='https://github.com/RocketChat/Rocket.Chat.Electron'
license=('MIT')
-_electron=electron21
+_electron=electron22
depends=("$_electron" 'nodejs' 'libvips')
makedepends=('node-gyp' 'yarn' 'asar')
install=rocketchat-desktop.install
changelog=CHANGELOG.md
source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver/$pkgname-$pkgver.tar.gz"
- rocketchat-desktop
rocketchat-desktop.desktop)
-sha256sums=('90541e721e4d8565a3fde75f13cb71bafd59c580f23128f304cb7b61338ac261'
- '1333c748e97f358d46d46f8b3808b74ccfc520f6bcd30aaf704b10b3512c9f21'
+sha256sums=('975e328c97c7db5718a641c8efd9f9022b8abcef2f04ea8ca388bc5d0074b56d'
'31fae4f98a61a774f84030fd43d2ef92c7633740dc5aa55967a21d0e29ea621a')
# validpgpkeys=('9EA06BE6FD613A03') # Tasso Evangelista
@@ -44,8 +42,11 @@ build() {
package() {
local i686=linux-ia32-unpacked x86_64=linux-unpacked aarch64=linux-arm64-unpacked
install -Dm644 -t "${pkgdir}/usr/share/applications" "${pkgname}.desktop"
- install -D -t "${pkgdir}/usr/bin" "$pkgname"
-
+ install -Dm755 /dev/null "${pkgdir}/usr/bin/$pkgname"
+ cat >>"${pkgdir}/usr/bin/$pkgname" <<EOD
+#! /usr/bin/sh
+exec $_electron /usr/lib/rocketchat-desktop "\$@"
+EOD
cd "Rocket.Chat.Electron-$pkgver"
install -Dm644 "build/icons/512x512.png" "$pkgdir/usr/share/icons/hicolor/512x512/apps/$pkgname.png"
install -Dm644 -t "${pkgdir}/usr/share/licenses/${pkgname}" LICENSE