summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorStephan Springer2023-01-02 17:07:44 +0100
committerStephan Springer2023-01-02 17:07:44 +0100
commit9a8f3f82fca4dd7d181998b50e908d0da36b83d2 (patch)
treedd3e371e8df9625deeadc17c92ee4902809e8e8e /PKGBUILD
parent248df9f11c5a47600c93607a735f1542cacaaaf8 (diff)
downloadaur-9a8f3f82fca4dd7d181998b50e908d0da36b83d2.tar.gz
fix arm64/aarch64 build, second try
patch by Manawyrm
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 93419966ef2f..ef70f5df8667 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=rocketchat-desktop
pkgver=3.8.15
-pkgrel=3
+pkgrel=4
pkgdesc='Rocket.Chat Native Cross-Platform Desktop Application via Electron.'
arch=('any')
url='https://github.com/RocketChat/Rocket.Chat.Electron'
@@ -30,7 +30,7 @@ prepare() {
build() {
cd "Rocket.Chat.Electron-$pkgver"
- local i686=ia32 x86_64=x64 aarch64=linux-arm64-unpacked
+ local i686=ia32 x86_64=x64
export NODE_ENV=production
export NODE_OPTIONS='--openssl-legacy-provider'
yarn build
@@ -40,7 +40,7 @@ build() {
}
package() {
- local i686=linux-ia32-unpacked x86_64=linux-unpacked
+ local i686=linux-ia32-unpacked x86_64=linux-unpacked aarch64=linux-arm64-unpacked
install -Dm644 -t "${pkgdir}/usr/share/applications" "${pkgname}.desktop"
install -D -t "${pkgdir}/usr/bin" "$pkgname"