summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTony Lambiris2017-07-01 15:18:18 -0400
committerTony Lambiris2017-07-01 15:18:18 -0400
commit9474eb6928ded6da371bd4293a2363cb454df7a6 (patch)
treef6cd9a6289f85bb740b0bc6507331ed2a02e178c /PKGBUILD
parent9777b6858ade1791ea235eccc79380b8300b2e3a (diff)
downloadaur-9474eb6928ded6da371bd4293a2363cb454df7a6.tar.gz
Version bump
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 7 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e5b37d051e9e..5fac4ce83851 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Tony Lambiris <tony@criticalstack.com>
pkgname=rocksdb-lite
-pkgver=5.4.6
+pkgver=5.5.1
pkgrel=1
pkgdesc='Embedded key-value store for fast storage (lite version)'
arch=(i686 x86_64)
@@ -10,11 +10,11 @@ license=(BSD)
depends=(gperftools zlib bzip2 lz4 snappy gcc-libs)
conflicts=(rocksdb)
checkdepends=(python2)
-source=(https://github.com/facebook/rocksdb/archive/rocksdb-$pkgver.zip)
-sha256sums=('b130935c3c59a3cdc0193a87f985d559b7f6bd26548fe039293172227ec8ae5a')
+source=(https://github.com/facebook/rocksdb/archive/v$pkgver.zip)
+sha256sums=('2f52fb05056999f565def3fb0b0e930e104f6ff30751388f29ee6a05a944647f')
prepare() {
- cd rocksdb-rocksdb-$pkgver
+ cd rocksdb-$pkgver
sed -e 's/\bpython\b/python2/' -i Makefile
if [ "$CARCH" == "armv6h" ]; then
sed -e 's/-momit-leaf-frame-pointer//' -i Makefile
@@ -22,18 +22,13 @@ prepare() {
}
build() {
- cd rocksdb-rocksdb-$pkgver
+ cd rocksdb-$pkgver
+ #CFLAGS='-DROCKSDB_LITE' make -j ${MAKEFLAGS} shared_lib
CFLAGS='-DROCKSDB_LITE' make shared_lib
}
-check() {
- cd rocksdb-rocksdb-$pkgver
-# The are some tests are broken in 3.6.2 release
-# make check
-}
-
package() {
- cd rocksdb-rocksdb-$pkgver
+ cd rocksdb-$pkgver
install -d "$pkgdir"/usr/include
cp -r include/rocksdb "$pkgdir"/usr/include
install -m755 -D librocksdb.so "$pkgdir"/usr/lib/librocksdb_lite.so